succsessful instalation on Ubuntu linux

  • Lukas

    Lukas - 2005-08-24

    hi 2 all!

    Here is how i insltalled on Ubuntu linux (since it is based on debian, maybe u can install it on other debian system in similar way.. ):

    1. downloaded a ubuntu linux .iso file, installed it on my mashine,and  logged in as root,
    2. copied, previously downloaded brl-cad file 'brlcad-7.4.0_linux_ia32.tar.gz' into /usr folder,
    3.opened a terminal, and wrote:

    tar -xvzf brlcad-7.4.0_linux_ia32.tar.gz

    4. this it extracted all package, into /usr directory. in which now i found another directory named 'usr' and inside it dir named 'brlcad' witch i copyed it into  /usr directory.. (so that i now have /usr/brlcad/..... )
    5.i opened terminal and wrote:

    export PATH=/usr/brlcad/bin:$PATH

    6. in terminal i wrote:


    ....and that's it , enjoy your cad! hope this will help someone..

    so, thanks, to all developers of this cad soft! anyway, it  seems rather sophisticaded software, maybe someone knows where can i find good tutorial?

    • Sean Morrison

      Sean Morrison - 2005-08-24

      Glad to hear you were able to install it and get it working.  The tarballs actually include full paths (e.g. /usr/brlcad/bin/...) given a limitation in how mged presently locates its data resources.  It has to be placed into /usr/brlcad if it's compiled for that location and cannot be relocated without a little bit of extra effort.  Regardless, you got the basic idea.  You can unpack the tar.gz anywhere and simply copy the usr/brlcad directory to /usr/brlcad and you'll be "installed".

      There are extensive tutorials on MGED available on the main website at that start out with the basics and it gets progressively more complicated.  See the Introduction to MGED and Principles of Effective Modeling documents listed there.


    • Nobody/Anonymous

      We are also using ubuntu but we have not installed BRL CAD yet. We are still looking for the right CAD for our needs. We are involved in digitizing and plotting maps, usually 2D. However, we want to do 3D models of our works in the future using digitized topographic maps. May I inquire if:
      1. BRL has 2D and can it import images to be digitized;
      2. BRL can open and save or export to dwg or dxf;
      3. BRL can plot GPS data or coordinates (longitude/latitude);
      4. BRL can use to HP plotters.

      Thank you.

      I am not registered yet but i can be known as anonymouse.

      • Sean Morrison

        Sean Morrison - 2005-10-07

        1. BRL has 2D and can it import images to be digitized;

        BRL-CAD includes several 2D image/data importers, converters, and manipulators as well as means for displaying images and storing them into the geometric databases.  The modeler mged, however, has very minimal support for managing 2D image data.  In mged, it's pretty much limited to storing the images into the .g file format as binary data sets (which could then be used as a texture or terrain data) and/or extracting those binary data sets to files.

        2. BRL can open and save or export to dwg or dxf;

        There is a dxf importer/exporter.  Some 2D-centric components usually found in a .dwg that have nothing to do with solid modeling are not converted.  For example, there's no support for "stipple lines" in drawings.  The drawings themselves can be converted as BRL-CAD sketch primitives.

        3. BRL can plot GPS data or coordinates (longitude/latitude);

        BRL-CAD has a "displacement map" primitive (dsp) that serves as a height field.  You provide a raw data file with up to 65k (unsigned short int, 16bit) levels of vertical resolution and arbitrary dimensions.  It pretty much gives you full control on your terrain grid and is only limited by how much memory you have.  Simple example of the Puget Sound dataset from Georgia Tech being visualized in mged:  (note: I accentuated the vertical elevation merely for visual effect)

        4. BRL can use to HP plotters.

        BRL-CAD does export in the '.pl' UNIX plot file format.  There are various converters and exporters as well as direct support in mged for saving the wireframe as a plot file or postscript file.  Whether or not those are formats that the newer HP plotters can read is something you'd probably have to look up with HP, though most any printer/plotter these days will read postscript.  If not, it wouldn't take much effort to convert a plot file to something else (it's a relatively simple text file format).

    • Nobody/Anonymous

      What does "export PATH=/usr/brlcad/bin:$PATH" do?
      When I typed mged, I got the error that "" couldn't be found.
      When I checked Synaptec, I found out that I do have libXxf86vm1, shouldn't that be the same?
      What other package do I need?

      • Sean Morrison

        Sean Morrison - 2005-10-26

        That export line adds /usr/brlcad/bin to the list of paths that your user shell search when looking for applications.  This path allows you to simply type "mged" and have it find the mged executable sitting in /usr/brlcad/bin/mged.

        The missing library sounds like the binary you're attempting to use was linked against a library that you do not have (libxxf86vm1).  If you have an Ubuntu or Debian system, you should be able to apt-get it.  If it's the .1 that's causing the trouble, you might be able to just create a symlink from to (or whatever it's named) in your lib directory.

        I'd start by trying to get the libxxf86vm1 package and making sure you have a symlink to the library if there's not a file/link that specifically says


    • Nobody/Anonymous

      I'll try that when I've time saturday. Thank you for the information. I'm still relatively new to Linux but it's coming together quite nicely. ;)

    • Nobody/Anonymous

      I want to test brl-cad on my ubuntu 5.10 -Breezy ..-
      I load the actual Version brlcad-7.6.4_linux_ia32.tar.gz down.
      Starting with 'mged' i get always the the same Error Massage:

      ./mged: error while loading shared libraries: cannot open share d object file: No such file or directory

      The librarie is not included in the unpacked file.
      Who can help ?

      • Sean Morrison

        Sean Morrison - 2006-01-28

        That binary version of BRL-CAD was compiled against a system library so it sounds like you'll need to make sure libtermio is installed.  If it is already installed, you can probably get away with making a symbolic link to it using exactly as the link name.  Otherwise you'll either need to wait for the next binary release (which shouldn't have the issue) or compile BRL-CAD yourself (which will avoid the issue).


    • Nobody/Anonymous

      I want to test brl-cad on my ubuntu 5.10 -Breezy ..-
      I get the same error-massage:
      .. cannot open shared object file: No such file or directory
      with the other binary-Files:

      but compiling brlcad-7.6.6.tar.gz, after extracting, with:

        make benchmark
        sudo make install
        make test

      workes fine.
      Thank's for your help Sean

    • Nobody/Anonymous

      > I want to test brl-cad on my ubuntu 5.10 -Breezy ..- 
      > I get the same error-massage:
      > .. cannot open shared object file: No such file or directory
      The libtermio is in the library dir of brlcad. It seems that some Vars are not set yet. A workaround would be to link them in the /bin dir.

      Rolf-Dieter Damm


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks