MGED segmentation fault on MacOS X 10.6.4

  • Kirk Johnson

    Kirk Johnson - 2010-10-23

    I'm having difficulty getting brlcad/mged working.  I noted several other threads/bug reports that I have tried and resulted in differing results.  Depending on how I try to compile, I noted the error in finding one of the dylib's as noted in a thread from a few months ago noting the recommendation to remove the PATH to the macports binaries.  I don't have macports installed but I do have fink installed, so I changed my PATH to avoid the fink directories.
    I have tried ./configure, ./configure -enable-optimized, ./configure -enable-all, ./configure -enable-tcl, ./configure -enable-tk, among others.  Each time running make distclean before going through the whole process again.
    I have been apparently successful in getting brlcad to compile but when I "make test", mged fails.  When I cd to the /brlcad-7.16.10/src/mged and sh mged I get a segmentation fault.
    Is there anything else I can try?  Will brlcad still work, but without mged?

  • Kirk Johnson

    Kirk Johnson - 2010-11-08

    Problem solved.  If anyone else has similar issues and finds this using a search engine, I'll include my steps for resolution.

    I configured using -enable-tk -enable-tcl -with-ogl

    make -j2 resulted in the following error

    Making all in db
    ../src/conv/asc2g operators.asc operators.asc2g
    dyld: Library not loaded: /usr/brlcad/lib/libwdb.19.dylib
      Referenced from: /*****/******/*****/brlcad-7.16.10/src/conv/.libs/asc2g
      Reason: image not found
    /bin/sh: line 1: 49243 Trace/BPT trap          LD_LIBRARY_PATH=../src/other/tcl/unix:../src/other/tk/unix:$LD_LIBRARY_PATH DYLD_LIBRARY_PATH=../src/other/tcl/unix:/src/other/tk/unix:$DYLD_LIBRARY_PATH ../src/conv/asc2g `if test -e operators.asc ; then echo operators.asc ; else echo ../db/operators.asc ; fi` operators.asc2g
    make: ***  Error 133
    make: ***  Error 1

    The key to success was a response to a similar post here "" as shown below.

    The existing install can confuse the runtime linker on some versions of Mac OS X.  That said, the error is fairly benign as everything is compiled by that point in the build process.  You should be able to "make install" successfully now.  A subsequent "make" run *after* make install should also work.

    So, I went ahead and issued "make install" and after the installation issued "make -j2" again which resulted in no errors this time.

    The installation functions as intended.

  • Sean Morrison

    Sean Morrison - 2010-11-08

    Glad to hear your problem is solved.  We have a new cmake-based build system under development that should not have this problem due to be unveiled later this year.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks