Can't get `mged` to run in OSX (Intel)

Help
2006-12-20
2013-04-22
  • Jack Gruendler

    Jack Gruendler - 2006-12-20

    Hi, I just installed BRL-CAD 7.6.6 (from BRL-CAD-7.6.6.dmg) on my iMac Core Duo running OSX 10.4.8. I added /usr/brlcad/bin to my $PATH, started X11.app, and tried typing `mged` first in Terminal.app, and then in an xterm. In both cases, I get this:

    $ mged
    Initializing and backgrounding, please wait...X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  129 (Apple-DRI)
      Minor opcode of failed request:  1 ()
      Serial number of failed request:  34
      Current serial number in output stream:  34
    Detached

    And then the process ends. What's wrong, and how do I fix it?

     
    • Sean Morrison

      Sean Morrison - 2006-12-20

      I only partially remember investigating this problem a couple months back when it first happened.  I believe the problem is that the Intel-binary X11 server has a bug where it cannot correctly communicate with a PPC-binary X11 binary application.  There are two possible work-arounds.  One is to compile BRL-CAD yourself, which is rather trivial if you have tha Apple developer tools installed (./autogen.sh && ./configure --enable-optimized && make && sudo make install).  The other option, I believe is to run MGED in "classic" console mode where the X11 interaction is minimal.  To do that, run mged with the "-c" option (e.g. mged -c moss.g) and it should open.  It won't give yout the entire gui, but the entire command-line capability should be at your disposal (covered somewhat in the /usr/brlcad/share/ html docs directory).  The next realease of a BRL-CAD binary for Mac OS X will be a universal binary so that you don't have this problem.

      Cheers!
      Sean

       
      • Jack Gruendler

        Jack Gruendler - 2006-12-21

        Hmm... I tried compiling it myself (although without the `--enable-optimized`), and now it shows a jumping dock icon for a moment and then gives me an OSX "The application mged quit unexpectedly." dialog box, and only prints the following to the terminal:

        $ mged
        Initializing and backgrounding, please wait...Detached

         
        • Sean Morrison

          Sean Morrison - 2006-12-21

          It sounds like either you're not running X11 (which is unfortunately still required for the time being with mged) or there's some other OpenGL issue.  Instead of running the application from Terminal, try running it from X11/xterm and see if it starts up correctly.

           
          • Jack Gruendler

            Jack Gruendler - 2006-12-21

            Sorry, I should have been more specific: as before, I tried both with Terminal.app and xterm.

            Could you elaborate on what kind of OpenGL issue it might be? OpenGL seems to be working just fine for every other program...

            Is there anything I could do to get more debugging output, maybe?

             
    • Nobody/Anonymous

      FWIW, I also see the same problem running on Fedora Core 5, compiled from source. arch is x86_64.

       
      • Sean Morrison

        Sean Morrison - 2008-05-24

        You should be able to add --without-opengl to your configure line and/or try a more recent release.

         
    • Nobody/Anonymous

      Also, I should mention that the brlcad-7.8.0_linux_x86_64.tar.bz2 package gives the same errors. So there's probably a mismatch between the code and the X11/GTK libraries somewhere, for this architecture.

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks