#68 Tree cmd not accepting args.

closed-fixed
Modeling (29)
5
2006-08-22
2006-05-02
David Loman
No

Tree command in version 7.8.0 will only accept -c. -
o, -i # are not working.

For the given command:

mged> tree -o filename.txt group1

it returns the following:

[proper tree of group1 here]
db_lookup(-o) failed: -o does not exist
db_lookup(filename) failed: filename does not exist

additionally, for:

mged> tree -i 2 group1

it returns the following:

[proper tree of group1 here]
db_lookup(-i) failed: -i does not exist
db_lookup(2) failed: 2 does not exist

Did these features get taken out of the command? if
so the man pages and help cmd need to be updated.

The only workaround i have found to this is to use an
older version. 7.4.0 is the latest (besides 7.8.0)
that i could test on and tree -o works fine on 7.4.0.

Understanding that its not a major bug, but rather
trivial, I am still available for information if
needed. david.h.loman@arl.army.mil

Thanks!

Discussion

  • John Anderson

    John Anderson - 2006-08-22

    Logged In: YES
    user_id=1185553

    This issue has been resolved in the latest CVS, thanks!

     
  • John Anderson

    John Anderson - 2006-08-22
    • assigned_to: nobody --> johnranderson
    • status: open --> closed-fixed
     
  • John Anderson

    John Anderson - 2006-08-22

    Logged In: YES
    user_id=1185553

    The capabilities claimed by the help command were not
    implemented in the code. I added the expected capabilities.
    The output of the command without the newly added options is
    identical to the old version of the command.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks