#241 no X11 or AquaTk

unexpected behavior
closed-later
3
2010-04-11
2010-02-01
Ben Ward
No

|
configure:33292: result: no
configure:33314: WARNING: Neither X11 nor AquaTk are usable, disabling Tk
configure:33561: }}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}
configure:33563: WARNING: Support for a BRL-CAD graphical user interface (GUI) will be disabled.
configure:33565: Try installing X11 development headers or system Tcl/Tk libraries.
configure:33567: MGED will still work in classic console mode but without a GUI.
configure:33569: {{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{
configure:33581: checking for incrTcl library functionality

<<<< and what is the point of having a solid geometry modelling software if you still have to "imagine what it looks like". It appears that the compiler/configurer is expecting X11 to be in /usr but my X11 is actually in /usr/share/X11/ I also have a directory in /usr/lib/X11 but this directory is empty do I need to somehow guide the compiler to /usr/share/X11 instead? and how?

the full config.log is attached but here is info near the top to indicate info about the machine--so people can read it before digging any further.
uname -m = i686
uname -r = 2.6.31.12-174.2.3.fc12.i686
uname -s = Linux
uname -v = #1 SMP Mon Jan 18 20:22:46 UTC 2010

/usr/bin/uname -p = unknown
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
/usr/bin/hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/local/bin
PATH: /usr/bin
PATH: /bin

Discussion

1 2 > >> (Page 1 of 2)
  • Ben Ward

    Ben Ward - 2010-02-01

    config.log generated when the above error occurred

     
  • Sean Morrison

    Sean Morrison - 2010-02-01

    If X11 is installed into non-standard locations (i.e., locations that automake is not prepared to look at by default), then you have to supply the appropriate build flags. You can try setting the --with-x11 flag on configure, or set the corresponding ldflags/cflags/cxxflags/cppflags to the corresponding directories where X11 resides.

    Note that it may simply be a matter that you do not have the X11 developer headers and libraries installed. They are usually a separate installable package for most package management systems (such as Debian's apt system and Gentoo's portage). Consult their docs to figure out what you need to have installed. Nominally, you should be able to find an X11.h header and a libX11.so (among various others required)..

     
  • Sean Morrison

    Sean Morrison - 2010-02-01
    • assigned_to: nobody --> brlcad
    • status: open --> pending-invalid
     
  • Ben Ward

    Ben Ward - 2010-02-02

    I attempted to configure using the --with-x11, with no success.
    As this is not what my primary area of expertise, specifically how would I go about setting these ldflags/cflags/cxxflags/cppflags to there corresponding directories? It is essentially a freshly installed Fedora 12 linux distribution, so I'm a bit suprised (if not ignorant) as to why the X11 would be in a non-default directory.
    I will mess with it some more, but am essentially running out of experiments.
    thanks.

     
  • Ben Ward

    Ben Ward - 2010-02-02
    • status: pending-invalid --> open-invalid
     
  • Sean Morrison

    Sean Morrison - 2010-02-02
    • priority: 5 --> 3
    • status: open-invalid --> pending-invalid
     
  • Sean Morrison

    Sean Morrison - 2010-02-02

    If it's a default Fedora install, then you undoubtedly don't have the development components installed and *that* is the problem. Try: yum install xorg-x11-devel

    You may also need more, but start there and retry configure. Try without any configure options first, then with flags if the error is not obvious. Otherwise, provide the result output/errors here to see what else you might need to install.

     
  • Ben Ward

    Ben Ward - 2010-02-03

    I attempted to do the yum install xorg-x11-devel and received "no package xorg-x11-devel available" nothing to do.
    so I attempted various capitalization and abbreviations, but received this same error.. so I attempted the following
    [root@kalkulon brlcad-7.16.4]# apt-get install xorg-x11-devel
    Reading Package Lists... Done
    Building Dependency Tree... Done
    E: Couldn't find package xorg-x11-devel
    [root@kalkulon brlcad-7.16.4]# apt-get install xorg-x11
    Reading Package Lists... Done
    Building Dependency Tree... Done
    Package xorg-x11 has no available version, but exists in the database.
    This typically means that the package was mentioned in a dependency and
    never uploaded, has been obsoleted or is not available with the contents
    of sources.list
    However the following packages replace it:
    xorg-x11-resutils xorg-x11-xkb-utils
    E: Package xorg-x11 has no installation candidate
    [root@kalkulon brlcad-7.16.4]# apt-get install xorg-x11-resutils
    Reading Package Lists... Done
    Building Dependency Tree... Done
    xorg-x11-resutils is already the newest version.
    0 upgraded, 0 newly installed, 0 removed and 0 not upgraded.
    [root@kalkulon brlcad-7.16.4]# apt-get install xorg-x11-xkb-utils
    Reading Package Lists... Done
    Building Dependency Tree... Done
    xorg-x11-xkb-utils is already the newest version.
    0 upgraded, 0 newly installed, 0 removed and 0 not upgraded.
    [root@kalkulon brlcad-7.16.4]#

    So it says that I already have 'the newest version' of those available package lists, which replace the xorg-x11 package. So just to see I attempted to configure the brl-cad package again. with this result.

    checking for X11 in /usr/X11... not found
    checking for X... (cached) no
    checking for X11/Xlib.h... (cached) no
    checking for XCreateWindow in -lX11... (cached) no
    checking for XShapeCombineMask in -lXext... (cached) no
    checking for XGetExtensionVersion in -lXi... (cached) no
    configure: }}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}}
    configure: WARNING: X11 support is enabled but the Xi library was not found.
    configure: WARNING: This will likely result in a build failure.
    configure: WARNING: See config.log for details why (look for this comment)
    configure: {{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{{
    checking for cos in -lm... (cached) yes
    checking for regcomp in -lc... (cached) yes

    a little further down,
    ecking for sys/param.h... (cached) yes
    checking for Tcl public headers... (cached) /home/ben/Downloads/brlcad-7.16.4/src/other/tcl/generic
    checking for Tk public headers... (cached) /home/ben/Downloads/brlcad-7.16.4/src/other/tk/generic
    checking for X... (cached) no
    checking for X11 header files... checking for X11 libraries... checking for XCreateWindow in -lXwindow... (cached) no
    could not find any! Using -lX11.
    checking for pthread_mutex_init in -lpthread... (cached) yes
    checking for building with threads... yes (default)
    configure: WARNING:
    --enable-threads requested, but building against a Tcl that is NOT
    thread-enabled. This is an OK configuration that will also run in
    a thread-enabled core.
    checking how to build libraries... shared
    checking if 64bit support is requested...

    and this other error, which I'm not sure if it is going to matter yet.
    config.status: executing depfiles commands
    config.status: executing libtool commands
    /bin/rm: cannot remove `libtoolT': No such file or directory
    === configuring in src/other/tcl/unix (/home/ben/Downloads/brlcamake[3]: *** [mged-adc.o] Error 1
    make[3]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src/mged'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src/mged'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src'
    make: *** [all-recursive] Error 1

    so at this point I thought I'd go ahead and do make, and when it was done I got these results/errors
    make[3]: *** [mged-adc.o] Error 1
    make[3]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src/mged'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src/mged'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src'
    make: *** [all-recursive] Error 1

    and at this point saw no purpose in running make install.
    I will upload the latest config.log file resulting from the things I've stated here

     
  • Ben Ward

    Ben Ward - 2010-02-03
    • status: pending-invalid --> open-invalid
     
  • Ben Ward

    Ben Ward - 2010-02-03

    config.log after attempting yum install xorg-x11-devel

     
  • Ben Ward

    Ben Ward - 2010-02-03

    I attempted some more poking around, and essentially tried to yum up whatever I could get for/from xorg-x11 and fc.12
    so I tried #yum install libx11-devel and recieved libx11-devel-1.3.1-1.fc12.i686 already installed and latest version
    and also tried
    [root@kalkulon brlcad-7.16.4]# yum install xorg-x11-drv-synaptics.i686
    Loaded plugins: presto, refresh-packagekit
    Setting up Install Process
    Package xorg-x11-drv-synaptics-1.2.1-1.fc12.i686 already installed and latest version
    Nothing to do
    [root@kalkulon brlcad-7.16.4]#

    but still can't compile brl-cad, and when I view /usr/lib/X11 it is still empty
    [ben@kalkulon lib]$ cd X11
    [ben@kalkulon X11]$ ls
    [ben@kalkulon X11]$ ls -l
    total 0
    [ben@kalkulon X11]$

    so if my packages are the latest versions? where are they, so that I might be able to pass them to the compiler?
    or should I be looking for something like xorg instead? here is what I find in /usr/lib/xorg/modules
    d ..
    [ben@kalkulon lib]$ cd xorg
    [ben@kalkulon xorg]$ ls
    modules protocol.txt
    [ben@kalkulon xorg]$ cd modules
    [ben@kalkulon modules]$ ls
    drivers libexa.so libshadowfb.so libvgahw.so linux
    extensions libfb.so libshadow.so libwfb.so multimedia
    input libint10.so libvbe.so libxaa.so
    [ben@kalkulon modules]$
    and poking through the subdirectories didn't reveal anything profound (at least not related to this project)
    so I am sort of ... well, LOST at this moment.

     
  • Ben Ward

    Ben Ward - 2010-02-06

    I thought perhaps the repositories may have been "unavailable" last time I tried to complete the yum install xorg-x11-devel ... So I tried again today and received this output.

    [ben@kalkulon ~]$ su
    Password:
    [root@kalkulon ben]# yum install xorg-x11-devel
    Loaded plugins: presto, refresh-packagekit
    updates/metalink | 15 kB 00:00
    updates | 4.4 kB 00:00
    updates/primary_db | 3.1 MB 00:08
    Setting up Install Process
    No package xorg-x11-devel available.
    Nothing to do
    [root@kalkulon ben]#

    This makes me wonder if I need to do something to setup YUM. Another thought is that this package is just no longer available/supported--which seems unlikely since it has been around for so long, and it should still be available for older, less powerful machines.

    Thanks for helping.

     
  • Ben Ward

    Ben Ward - 2010-02-09

    so essentially I ran out of patience, and ran #yum install xorg-x11* which may not have been totally wise, but it did solve my error, while also adding ethiopian support and a bunch of other things I will most likely never need.

    currently I have run into this error which I am working the kinks out.
    me/ben/Downloads/brlcad-7.16.4/src/burst'
    make[2]: Nothing to be done for `all'.
    make[2]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src/burst'
    Making all in bwish
    make[2]: Entering directory `/home/ben/Downloads/brlcad-7.16.4/src/bwish'
    /bin/sh ../../libtool --silent --tag=CC --silent --mode=link gcc -DBWISH=1 -I../../src/other/incrTcl/itcl/generic -I../../src/other/incrTcl/itk/generic -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -I../../src/other/tk/win -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -pipe -fno-strict-aliasing -fno-common -fexceptions -g -L/usr/local/lib -pipe -fno-strict-aliasing -fno-common -fexceptions -g -o bwish bwish-cmd.o bwish-input.o bwish-main.o bwish-tcl.o ../../src/libtclcad/libtclcad.la ../../src/libdm/libdm.la ../../src/other/incrTcl/libitk.la ../../src/other/incrTcl/libitcl.la -L../../src/other/tk/unix -ltk8.5 -L../../src/other/tcl/unix -ltcl8.5 -ldl -lm ../../src/libtermio/libtermio.la
    bwish-cmd.o: In function `cmdInit':
    /home/ben/Downloads/brlcad-7.16.4/src/bwish/cmd.c:371: undefined reference to `tkImgFmtPIX'
    collect2: ld returned 1 exit status
    make[2]: *** [bwish] Error 1
    make[2]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src/bwish'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/ben/Downloads/brlcad-7.16.4/src'
    make: *** [all-recursive] Error 1

    I'll post/update what I learned from resolving it.

     
  • Sean Morrison

    Sean Morrison - 2010-02-12

    Your latest error doesn't make a whole lot of sense and may simply indicate your compilation is in some peculiar state from rerunning make. It's complaining about a missing symbol that should be provided by a library that it's linking in. What does this output:

    nm src/libtclcad/.libs/libtclcad.a | grep tkImgFmtPIX

    It should report something like this:

    sushi:~/brlcad morrison$ nm src/libtclcad/.libs/libtclcad.a|grep tkImgFmtPIX
    ../libtclcad/.libs/libtclcad.a(libtclcad_la-tkImgFmtPIX.o):
    00000720 D _tkImgFmtPIX

    If it does, then try running this and report the output:

    cd src/bwish
    /bin/sh ../../libtool --tag=CC --mode=link gcc -DBWISH=1 -I../../src/other/incrTcl/itcl/generic -I../../src/other/incrTcl/itk/generic -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -I../../src/other/tk/win -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -pipe -fno-strict-aliasing -fno-common -fexceptions -g -L/usr/local/lib -pipe -fno-strict-aliasing -fno-common -fexceptions -g -o bwish bwish-cmd.o bwish-input.o bwish-main.o bwish-tcl.o ../../src/libtclcad/libtclcad.la ../../src/libdm/libdm.la ../../src/other/incrTcl/libitk.la ../../src/other/incrTcl/libitcl.la -L../../src/other/tk/unix -ltk8.5 -L../../src/other/tcl/unix -ltcl8.5 -ldl -lm ../../src/libtermio/libtermio.la

     
  • Sean Morrison

    Sean Morrison - 2010-02-12
    • status: open-invalid --> pending-invalid
     
  • SourceForge Robot

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending-invalid --> closed-invalid
     
  • Sean Morrison

    Sean Morrison - 2010-04-06

    Benett, please reply to the original request from 2010-02-12 with the output from 'nm' and reporting the output of the second commands in the src/bwish directory.

     
  • Sean Morrison

    Sean Morrison - 2010-04-06
    • status: closed-invalid --> pending-invalid
     
  • Ben Ward

    Ben Ward - 2010-04-10

    I tried to complete the secondary command from your post on 2-12-2010, and have included the output. I didn't seem to get much useful information, so either something is missing, or I screwed up the command.. I will easily admit ignorance in this situation.
    Thanks. here is the copied input/output of what I tried. Also, after the first attempt screwed up, I copied and pasted, so there may have been some random <carriage returns> that screwed up how my command was interpreted.

    [ben@kalkulon brlcad-7.16.4]$ cd src
    [ben@kalkulon src]$ cd bwish
    [ben@kalkulon bwish]$ ls
    btclsh btclsh-tcl.o bwish-tcl.o input.c Makefile.in
    btclsh-cmd.o bwish-cmd.o cadAppInit.c main.c tcl.c
    btclsh-input.o bwish-input.o cmd.c Makefile unixMain.c
    btclsh-main.o bwish-main.o consoleMain.c Makefile.am winMain.c

    [ben@kalkulon bwish]$ /bin/sh ../../libtool --tag=CC --mode=link gcc -DBWISH=1
    libtool: link: you must specify an output file
    libtool: link: Try `libtool --help --mode=link' for more information.
    [ben@kalkulon bwish]$ /bin/sh ../../libtool --tag=CC --mode=link gcc -DBWISH=1 -l../../src/other/incrTcl/itcl/generic
    libtool: link: you must specify an output file
    libtool: link: Try `libtool --help --mode=link' for more information.
    [ben@kalkulon bwish]$
    [ben@kalkulon bwish]$ cd src/bwish
    bash: cd: src/bwish: No such file or directory
    [ben@kalkulon bwish]$ /bin/sh ../../libtool --tag=CC --mode=link gcc -DBWISH=1
    libtool: link: you must specify an output file
    libtool: link: Try `libtool --help --mode=link' for more information.
    [ben@kalkulon bwish]$ -I../../src/other/incrTcl/itcl/generic
    bash: -I../../src/other/incrTcl/itcl/generic: No such file or directory
    [ben@kalkulon bwish]$ -I../../src/other/incrTcl/itk/generic -I../../src/other/tcl/generic
    bash: -I../../src/other/incrTcl/itk/generic: No such file or directory
    [ben@kalkulon bwish]$ -I../../src/other/tcl/unix -I../../src/other/tk/generic
    bash: -I../../src/other/tcl/unix: No such file or directory
    [ben@kalkulon bwish]$ -I../../src/other/tk/unix -I../../src/other/tk/win
    bash: -I../../src/other/tk/unix: No such file or directory
    [ben@kalkulon bwish]$ -I../../src/other/tcl/generic -I../../src/other/tcl/unix
    bash: -I../../src/other/tcl/generic: No such file or directory
    [ben@kalkulon bwish]$ -I../../src/other/tk/generic -I../../src/other/tk/unix -pipe
    bash: -I../../src/other/tk/generic: No such file or directory
    [ben@kalkulon bwish]$ -fno-strict-aliasing -fno-common -fexceptions -g -L/usr/local/lib -pipe
    Command not found.
    * Waiting in queue..
    [ben@kalkulon bwish]$ -fno-strict-aliasing -fno-common -fexceptions -g -o bwish bwish-cmd.o
    Command not found.
    * Waiting in queue..
    [ben@kalkulon bwish]$ bwish-input.o bwish-main.o bwish-tcl.o ../../src/libtclcad/libtclcad.la
    Command not found.
    * Waiting in queue..
    [ben@kalkulon bwish]$ ../../src/libdm/libdm.la ../../src/other/incrTcl/libitk.la
    bash: ../../src/libdm/libdm.la: Permission denied
    [ben@kalkulon bwish]$ ../../src/other/incrTcl/libitcl.la -L../../src/other/tk/unix -ltk8.5
    bash: ../../src/other/incrTcl/libitcl.la: Permission denied
    [ben@kalkulon bwish]$ -L../../src/other/tcl/unix -ltcl8.5 -ldl -lm
    bash: -L../../src/other/tcl/unix: No such file or directory
    [ben@kalkulon bwish]$ ../../src/libtermio/libtermio.la
    bash: ../../src/libtermio/libtermio.la: Permission denied
    [ben@kalkulon bwish]$ su
    Password:
    [root@kalkulon bwish]#
    [root@kalkulon bwish]# cd src/bwish
    bash: cd: src/bwish: No such file or directory
    [root@kalkulon bwish]# /bin/sh ../../libtool --tag=CC --mode=link gcc -DBWISH=1
    libtool: link: you must specify an output file
    libtool: link: Try `libtool --help --mode=link' for more information.
    [root@kalkulon bwish]# -I../../src/other/incrTcl/itcl/generic
    bash: -I../../src/other/incrTcl/itcl/generic: No such file or directory
    [root@kalkulon bwish]# -I../../src/other/incrTcl/itk/generic -I../../src/other/tcl/generic
    bash: -I../../src/other/incrTcl/itk/generic: No such file or directory
    [root@kalkulon bwish]# -I../../src/other/tcl/unix -I../../src/other/tk/generic
    bash: -I../../src/other/tcl/unix: No such file or directory
    [root@kalkulon bwish]# -I../../src/other/tk/unix -I../../src/other/tk/win
    bash: -I../../src/other/tk/unix: No such file or directory
    [root@kalkulon bwish]# -I../../src/other/tcl/generic -I../../src/other/tcl/unix
    bash: -I../../src/other/tcl/generic: No such file or directory
    [root@kalkulon bwish]# -I../../src/other/tk/generic -I../../src/other/tk/unix -pipe
    bash: -I../../src/other/tk/generic: No such file or directory
    [root@kalkulon bwish]# -fno-strict-aliasing -fno-common -fexceptions -g -L/usr/local/lib -pipe
    Command not found.
    * Waiting in queue..
    [root@kalkulon bwish]# -fno-strict-aliasing -fno-common -fexceptions -g -o bwish bwish-cmd.o
    Command not found.
    * Waiting in queue..
    [root@kalkulon bwish]# bwish-input.o bwish-main.o bwish-tcl.o ../../src/libtclcad/libtclcad.la
    Command not found.
    * Waiting in queue..
    [root@kalkulon bwish]# ../../src/libdm/libdm.la ../../src/other/incrTcl/libitk.la
    bash: ../../src/libdm/libdm.la: Permission denied
    [root@kalkulon bwish]# ../../src/other/incrTcl/libitcl.la -L../../src/other/tk/unix -ltk8.5
    bash: ../../src/other/incrTcl/libitcl.la: Permission denied
    [root@kalkulon bwish]# -L../../src/other/tcl/unix -ltcl8.5 -ldl -lm
    bash: -L../../src/other/tcl/unix: No such file or directory
    [root@kalkulon bwish]# ../../src/libtermio/libtermio.la
    bash: ../../src/libtermio/libtermio.la: Permission denied
    [root@kalkulon bwish]#

     
  • Ben Ward

    Ben Ward - 2010-04-10
    • status: pending-invalid --> open-invalid
     
  • Ben Ward

    Ben Ward - 2010-04-10

    I tried that secondary command from your reply post on 2-12-2010, while copy & pasting it and editing out the <CR>. I had manually navigated into the src/bwish directory, and ran the command as root. Here is my input/output (so you can see if I messed up while entering the command itself).

    [root@kalkulon bwish]# -I../../src/other/incrTcl/itcl/generic
    bash: -I../../src/other/incrTcl/itcl/generic: No such file or directory
    [root@kalkulon bwish]# /bin/sh ../../libtool --tag=CC --mode=link gcc -DBWISH=1 -I../../src/other/incrTcl/itcl/generic -I../../src/other/incrTcl/itk/generic -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -I../../src/other/tk/win -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -pipe -fno-strict-aliasing -fno-common -fexceptions -g -L/usr/local/lib -pipe -fno-strict-aliasing -fno-common -fexceptions -g -o bwish bwish-cmd.o bwish-input.o bwish-main.o bwish-tcl.o ../../src/libtclcad/libtclcad.la ../../src/libdm/libdm.la ../../src/other/incrTcl/libitk.la ../../src/other/incrTcl/libitcl.la -L../../src/other/tk/unix -ltk8.5 -L../../src/other/tcl/unix -ltcl8.5 -ldl -lm ../../src/libtermio/libtermio.la
    libtool: link: gcc -DBWISH=1 -I../../src/other/incrTcl/itcl/generic -I../../src/other/incrTcl/itk/generic -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -I../../src/other/tk/win -I../../src/other/tcl/generic -I../../src/other/tcl/unix -I../../src/other/tk/generic -I../../src/other/tk/unix -pipe -fno-strict-aliasing -fno-common -fexceptions -g -pipe -fno-strict-aliasing -fno-common -fexceptions -g -o .libs/bwish bwish-cmd.o bwish-input.o bwish-main.o bwish-tcl.o -L/usr/local/lib ../../src/libtclcad/.libs/libtclcad.so -L/home/ben/Downloads/brlcad-7.16.4/src/other/tcl/unix /home/ben/Downloads/brlcad-7.16.4/src/libdm/.libs/libdm.so /home/ben/Downloads/brlcad-7.16.4/src/other/incrTcl/.libs/libitcl.so -ltclstub8.5 ../../src/libdm/.libs/libdm.so /home/ben/Downloads/brlcad-7.16.4/src/libged/.libs/libged.so /home/ben/Downloads/brlcad-7.16.4/src/libwdb/.libs/libwdb.so /home/ben/Downloads/brlcad-7.16.4/src/librt/.libs/librt.so /home/ben/Downloads/brlcad-7.16.4/src/libbn/.libs/libbn.so /home/ben/Downloads/brlcad-7.16.4/src/libsysv/.libs/libsysv.so /home/ben/Downloads/brlcad-7.16.4/src/other/openNURBS/.libs/libopenNURBS.so -lstdc++ /home/ben/Downloads/brlcad-7.16.4/src/libfb/.libs/libfb.so /home/ben/Downloads/brlcad-7.16.4/src/libbu/.libs/libbu.so -lc -lpthread /home/ben/Downloads/brlcad-7.16.4/src/libpkg/.libs/libpkg.so -lnsl /home/ben/Downloads/brlcad-7.16.4/src/other/libpng/.libs/libpng.so /home/ben/Downloads/brlcad-7.16.4/src/other/libz/.libs/libz.so ../../src/other/incrTcl/.libs/libitk.so ../../src/other/incrTcl/.libs/libitcl.so -L/home/ben/Downloads/brlcad-7.16.4/src/other/tk/unix -ltk8.5 -ltcl8.5 -ldl -lm ../../src/libtermio/.libs/libtermio.so /home/ben/Downloads/brlcad-7.16.4/src/other/libtermlib/.libs/libtermlib.so -Wl,-rpath -Wl,/usr/brlcad/lib
    bwish-cmd.o: In function `cmdInit':
    /home/ben/Downloads/brlcad-7.16.4/src/bwish/cmd.c:371: undefined reference to `tkImgFmtPIX'
    collect2: ld returned 1 exit status
    [root@kalkulon bwish]#

     
  • Ben Ward

    Ben Ward - 2010-04-10
    • status: open-invalid --> open
     
  • Sean Morrison

    Sean Morrison - 2010-04-11
    • status: open --> closed-later
     
  • Sean Morrison

    Sean Morrison - 2010-04-11

    Ben, unfortunately, this line of attack isn't being very productive. You original paste wasn't right and while the secondary attempt is much better, still leaves us back at the beginning and in need of further diagnostic information. My suggestion is still to simply wait for the release or to start from scratch with an SVN checkout instead of 7.16.4.

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks