No audio at all.

Help
2010-08-07
2013-05-23
  • Nobody/Anonymous

    When I start Bristol I get no audio when I click on a key.
    I read the site So am I missing something?
    i tried to use startBristol -obx -alsa and still no audio.

     
  • Nick Copeland

    Nick Copeland - 2010-08-08

    Do you use Jack for the audio? Can you get me the output from the following commands:

    startBristol -obx -console
    startBristol -obx -alsa -console

    That will give me a bit more data to look at and try and find out what is going wrong.

    Regards ,nick

     
  • Nobody/Anonymous

    This is what the 1st command gave:
    checking availability of TCP port 5028
    using port 5028
    generate bandwidth limited waveforms(31, 12)
    spawning midi thread
    could not reschedule thread
    parent going into idle loop
    Init waiting for midi thread OK status
    Fixing samplerate at 44100
    midi sequencer: bristol
    Opened listening control socket: 5028
    midiOpen: 5028(100)
    Client ID = 128
    Queue ID = 0
    Registered 128 0
    Device name "bristol" did not parse, defaults 128.0
    Got midi thread OK status
    bristol version 0.40.8
    connected to :0.0
    display is 1280 by 1024 pixels
    Window is w 1280, h 1024, d 24, 0 0 0
    Using DirectColor display
    Initialise the obx link to bristol: 92a66d8
    hostname is localhost, bristol
    TCP port: 5028
    Accepted connection from 0 (3) onto 2 (5)
    Connected to the bristol control socket: 4
    bristolengine already active
    created 32 voices: allocated 32 to synth
    sid is 0
    spawning audio thread
    could not reschedule thread
    init waiting for audio thread OK status
    bristolAudioOpen(plughw:0,0, 44100, 256, 1a00008)
    audioOpen(0074f080, 0, 1024): plughw:0,0
    opening device plughw:0,0, flags 0000000d
    open playback on plughw:0,0, pre 8
    Plug PCM: Hardware PCM card 0 'HDA Intel' device 0 subdevice 0
    Its setup is:
      stream       : PLAYBACK
      access       : RW_INTERLEAVED
      format       : S16_LE
      subformat    : STD
      channels     : 2
      rate         : 44100
      exact rate   : 44100 (44100/1)
      msbits       : 16
      buffer_size  : 2048
      period_size  : 256
      period_time  : 5804
      tstamp_mode  : NONE
      period_step  : 1
      avail_min    : 256
      period_event : 0
      start_threshold  : 2147483647
      stop_threshold   : 2048
      silence_threshold: 0
      silence_size : 0
      boundary     : 1073741824
      appl_ptr     : 0
      hw_ptr       : 0
    open capture on plughw:0,0: pre 8
    Plug PCM: Hardware PCM card 0 'HDA Intel' device 0 subdevice 0
    Its setup is:
      stream       : CAPTURE
      access       : RW_INTERLEAVED
      format       : S16_LE
      subformat    : STD
      channels     : 2
      rate         : 44100
      exact rate   : 44100 (44100/1)
      msbits       : 16
      buffer_size  : 2048
      period_size  : 256
      period_time  : 5804
      tstamp_mode  : NONE
      period_step  : 1
      avail_min    : 256
      period_event : 0
      start_threshold  : 2147483647
      stop_threshold   : 2048
      silence_threshold: 0
      silence_size : 0
      boundary     : 1073741824
      appl_ptr     : 0
      hw_ptr       : 0
    opened audio device with a fragment size of 1024, buffer 8e74b30, fd 7/8
    setAudioStart2(0)

    2nd command:
    checking availability of TCP port 5028
    using port 5028
    generate bandwidth limited waveforms(31, 12)
    spawning midi thread
    could not reschedule thread
    Fixing samplerate at 44100
    parent going into idle loop
    Init waiting for midi thread OK status
    midi sequencer: bristol
    Opened listening control socket: 5028
    midiOpen: 5028(100)
    Client ID = 128
    Queue ID = 0
    Registered 128 0
    Device name "bristol" did not parse, defaults 128.0
    Got midi thread OK status
    bristol version 0.40.8
    connected to :0.0
    display is 1280 by 1024 pixels
    Window is w 1280, h 1024, d 24, 0 0 0
    Using DirectColor display
    Initialise the obx link to bristol: 95db6d8
    hostname is localhost, bristol
    TCP port: 5028
    Accepted connection from 0 (3) onto 2 (5)
    Connected to the bristol control socket: 4
    bristolengine already active
    created 32 voices: allocated 32 to synth
    sid is 0
    spawning audio thread
    could not reschedule thread
    init waiting for audio thread OK status
    bristolAudioOpen(plughw:0,0, 44100, 256, 1a00008)
    audioOpen(00ece080, 0, 1024): plughw:0,0
    opening device plughw:0,0, flags 0000000d
    open playback on plughw:0,0, pre 8
    Plug PCM: Hardware PCM card 0 'HDA Intel' device 0 subdevice 0
    Its setup is:
      stream       : PLAYBACK
      access       : RW_INTERLEAVED
      format       : S16_LE
      subformat    : STD
      channels     : 2
      rate         : 44100
      exact rate   : 44100 (44100/1)
      msbits       : 16
      buffer_size  : 2048
      period_size  : 256
      period_time  : 5804
      tstamp_mode  : NONE
      period_step  : 1
      avail_min    : 256
      period_event : 0
      start_threshold  : 2147483647
      stop_threshold   : 2048
      silence_threshold: 0
      silence_size : 0
      boundary     : 1073741824
      appl_ptr     : 0
      hw_ptr       : 0
    open capture on plughw:0,0: pre 8
    Plug PCM: Hardware PCM card 0 'HDA Intel' device 0 subdevice 0
    Its setup is:
      stream       : CAPTURE
      access       : RW_INTERLEAVED
      format       : S16_LE
      subformat    : STD
      channels     : 2
      rate         : 44100
      exact rate   : 44100 (44100/1)
      msbits       : 16
      buffer_size  : 2048
      period_size  : 256
      period_time  : 5804
      tstamp_mode  : NONE
      period_step  : 1
      avail_min    : 256
      period_event : 0
      start_threshold  : 2147483647
      stop_threshold   : 2048
      silence_threshold: 0
      silence_size : 0
      boundary     : 1073741824
      appl_ptr     : 0
      hw_ptr       : 0
    opened audio device with a fragment size of 1024, buffer 9677b30, fd 7/8
    setAudioStart2(0)
    Start playback
    Start capture
    Midi read retry (3052)
    initialising one obx
    No private microtonal mapping for obx
    veloc first 0.00 last 1.00
    user r 1000/1000, e 1000/1000
    Client ID = 129
    Queue ID = 1
    Registered 129 0
    Device name "brighton" did not parse, defaults 128.0
    opened GUI midi handles: 1, -1
    Read Configuration: obx
    brightonWorldChanged(770 350 10 10)
    going operational

    and when I use -jack:

    jackstats found -rate -count
    checking availability of TCP port 5028
    using port 5028
    generate bandwidth limited waveforms(31, 12)
    spawning midi thread
    could not reschedule thread
    parent going into idle loop
    Init waiting for midi thread OK status
    Fixing samplerate at 0
    midi sequencer: bristol
    Opened listening control socket: 5028
    midiOpen: 5028(100)
    Client ID = 128
    Queue ID = 0
    Registered 128 0
    Device name "bristol" did not parse, defaults 128.0
    Got midi thread OK status
    bristol version 0.40.8
    connected to :0.0
    display is 1280 by 1024 pixels
    Window is w 1280, h 1024, d 24, 0 0 0
    Using DirectColor display
    Initialise the obx link to bristol: 8be66d8
    hostname is localhost, bristol
    TCP port: 5028
    Accepted connection from 0 (3) onto 2 (5)
    Connected to the bristol control socket: 4
    bristolengine already active
    created 32 voices: allocated 32 to synth
    sid is 0
    spawning audio thread
    could not reschedule thread
    init waiting for audio thread OK status
    registering jack interface: bristol
    Cannot connect to jack

    Could not open the requested jack interface.

    The server may already be active with different user permissions, try starting
    bristol as root. It may be that the server cannot be started because the audio
    interface is in use by another application, that the server could not be found
    in the PATH variable, or that some parameter values did not match which should
    have been reported above

    return - no data in buffer for 0
    cleanupBrighton(0)
    cleared sigpipe handler
    cleanupBrighton(0)
    midi write error, fd 4, size 1
    return - no data in buffer for 0
    socket closed
    request acked: -1

     
  • Nobody/Anonymous

    Is this the 0.40.8 version that is deliivered with debian/ubuntu releases? I take it other applications do give you audio output, no?

    If you do have bristol from a package manager I would advise uninstalling it and getting a copy of 0.60 from this site and doing a full build. I can advise on how you can do that, depending on your system is might be a little or a lot of work but the issue is that I don't do the packaging and I don't know what dependencies they have built in to what they are distributing.

    If you want to have a go at that then let me know and we can work on your distribution and the dependencies you are likely to need.

    Kind regards, nick

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks