Can't get Bristol working (confused).

Chris W
  • Chris W

    Chris W - 2009-11-02


    I'm trying to get Bristol working.  First I tried the package in the repos for Ubuntu Karmic 64-bit.  It wouldn't work in ALSA or OSS, and complained there was no JACK driver compiled in it.

    Then I downloaded the source of 0.9.6-212 (the most recent one, I think) and compiled it.  That version still complained about not having JACK drivers.  When I tried it under ALSA, this is the output I got:

    generate bandwidth limited waveforms(31, 12)
    spawning midi thread
    Fixing samplerate at 44100
    parent going into idle loop
    Init waiting for midi thread OK status
    midi sequencer
    Opened listening control socket: 5028
    midiOpen: bristol(100)
    Error opening midi device bristol, exiting midi thread
    bristol version 0.40.1
    connected to :0.0
    display is 1680 by 1050 pixels
    Window is w 1680, h 1050, d 24, 0 0 0
    Using DirectColor display
    Initialise the mini link to bristol: 206c300
    hostname is localhost, bristol
    TCP port: 5028
    connect failed: Connection refused
    opening link to engine: -1
    hostname is localhost, bristol
    TCP port: 5028
    connect failed: Connection refused

    TCP!?  Why is it trying to connect to the internet!?

    Anyway, any help towards getting Bristol working on my system is appreciated.  I would prefer to use it with JACK, but ALSA is cool as along as I can play it with my Axis-49.  Can't wait to try it out!

  • Nick Copeland

    Nick Copeland - 2009-11-02

    Hi Chris,

    The version of bristol packaged as a dot deb file is very old - I don't maintain any distributions, this was put together a few years ago and never updated. You have got hold of a pretty recent release though: 0.40.1 and I did hear that somebody was going to put a bit of effort into keeping bristol in the distribution. Anyway, lets have a look at your installation, later we can decide if you really need 0.40.6 (or even .7 that is pending with a lot of bug fixes).

    Don't worry about the TCP: the GUI and engine talk to each other using MIDI over a TCP connection but they default to 'localhost' so they don't actually go out to the internet. I am a network engineer and decided that the possibility of having bristol distributed and knowing about TCP programming meant is was easy to build it in, it gives good separation between GUI and engine which is always a good approach.

    This next message is pretty important:

    Error opening midi device bristol, exiting midi thread

    This indicates that it could not open the default ALSA rawmidi interface. What options do you use to start the program, something like 'startBristol -juno' should give you ALSA audio and ALSA rawmidi and should just work. It can fail: if I cannot find the library and header files when you do the './configure' then it will fails some of the drivers, but it also gives indications as to what needs to be installed (ie, the dependencies) as the final output from the command. Hence, what did you get from './configure'? Also, if you try the following 'startBristol -midi alsa -juno' then it will may also fail with this message: the option -alsa configures ALSA flags for audio and MIDI, setting some default flags. If you select '-midi alsa' it clears out a number of those flags and starts again.

    We can get this working, I don't see that either 64bit or karmic should cause it to fail, I have had it working on 64bit 9.04.

    Kind regards, Nick


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks