Leslie speed problem

Help
2009-01-18
2013-05-23
  • Graham Wykes

    Graham Wykes - 2009-01-18

    Hi

    I have just installed Ubuntu Studio (8.10).  I understand that the version of bristol is old (0.9.13) but I thought I would give it a try anyway.

    It starts up fine with startBristol -audio alsa -midi alsa -b3.  The instrument is playable with the mouse on screen (and sounds VERY nice I must say! - congrats.), as are the mini and prophet.

    When I try aconnect -i and aconnect -o, bristol is not listed in either.  Neither does it show up in aconnectgui. ( I started vkeybd and it shows up ok in all of them).  I then tried alsamixer and it only showed pulseaudio.  I killed the pulseaudio process and made sure the sound configuration was set to alsa.  Alsamixer then shows everything. On restarting bristol, it still works but does not show up with aconnect. 

    I assume that this is a configuration problem with Ubuntu Studio's audio setup but I wanted to mention it in case it has any bearing on the real problem.

    When set to fast, the leslie speed is only a little faster than on slow (at about 2 Hz I think).  The H-freq control is set to max.  What am I doing wrong?

    Regards
    Graham

     
    • Nick Copeland

      Nick Copeland - 2009-01-19

      The Leslie speed controls work a little counter intuitive, some work is underway to change that. To start with the speed controls seem to work in reverse:

      fully clockwise is the lowest speed, fully anticlockwise is the highest speed.

      This in itself may be the cause of your issue however there are two speed controls, one each for high and low speeds so both of these can be changed so that there is little to no difference between the two speeds.

      The speed of rotation is also a function of the modwheel control (controller #1 from a typical synth) but that is a default mapping that does not work with all keyboards and may be removed. For a start most keyboards have the modwheel as free rolling - it stays where you move it however Roland/Edirol keyboards have the modwheel control as a return to zero movement which always results in a slow a slow speed for the Leslie unless the control is consistently pushed forward.

      I am not sure about the connections issue you saw, did you try 'startBristol -b3'? The only other thought I have is that 0.9.13 is extremely old and was built with similarly old alsa drivers. In contrast Ubuntu 8.10 has reasonably up to date alsa so there may be some compatibility issues, even if you recompiled bristol.

      Regards, Nick

       
    • Graham Wykes

      Graham Wykes - 2009-01-19

      Thanks Nick

      The controls are working with clockwise fastest so something strange is going on.  I also actually made a typo.  Synaptic reports the installed version as 0.9.1-13.  It's the version that is included in the latest Ubuntu Studio DVD iso so I assumed it should work.

      Being new to Linux, is this the correct way to find the installed version?

      I'll read up on installing the latest version - something I've never done apart from using synaptic.  It will be something of an adventure :)

      Regards
      Graham

       
    • Nick Copeland

      Nick Copeland - 2009-01-19

      Hi Graham,

      The fact that Ubuntu has such an old version is kind of my fault: I don't do packaging of Bristol for any distribution. Somebody once did one for Ubuntu Studio I think however that must be nearly three years ago now - 0.9.1 was then current however since then it has been revised to 0.30.3.

      Installing a new version should not be an issue. Get the current distribution from sourceforge to some directory - your browser may have a default location, otherwise just use /tmp or your home directory:

      http://sourceforge.net/project/showfiles.php?group_id=157415&package_id=175973&release_id=644603

      From your home directory (or perhaps make a subdirectory calld 'src' for example) do the following:

      cd
      cd src
      tar xfvpz /tmp/bristol-0.30.3.tar.gz
      <Snip lots of output>
      ./configure
      make
      sudo make install

      And that should really be it. Listen, that last few lines of output from './configure' are quite important, you want to make sure it finds ALSA and you will see that in the last few lines of the ./configure. If you have issues let me know - I will help you get through it as best I can from here and I will work to document any problems to put them at the top of the README file of the distribution. The thing is that you might also need to install 'alsadev' which is something from the synaptic package manager - its called libasound-dev and you can find it with a search. You might also get some issues with X libraries, just let me know and I will dig the details out of my email history.

      Kind regards,

      Nick.

       
    • Graham Wykes

      Graham Wykes - 2009-01-20

      Hi Nick

      ./configure tells me that alsa, jack and jack midi are "false" and that I need libX11-dev.

      When I go to synaptic it tells me that I have libasound2 and libasound2-plugins installed.  I can't find any listings of dev packages using synaptic. Even libX11-dev seems not to be available.  I have all the repositories enabled that are available so I don't know where to go from here.

      Regards
      Graham

       
    • Nick Copeland

      Nick Copeland - 2009-01-20

      Hi Graham,

      For the libasound stuff you need to open the Synaptic Package Manager and do a search for 'libasound', one of the packages listed should be 'libasound2-dev' which should be selected for install. That should solve the dependency on audio since the actual drivers should be installed. You can see that with the command 'lsmod' which will list a load of stuff starting with 'snd' - the different sound drivers modules.

      After that you need to do another search, this time for libx11, and this time one of the listed packages should be libx11-dev which also needs to be selected for install.

      When you have both of these selected you an Apply the changes and when finished try the ./configure again, this time it should recognise ALSA and X11 development as available. Apologies if this seems like a lot of work (it is more than it should be) but you are actually compiling an application that needs some guidance from the system to be possible. That 'guidance' comes from system header files and so they need to be installed first.

      For the time being I would not concern yourself with Jack - you can look into that later maybe when you want to start sharing audio between different applications. Ubuntu 8.10 already has a sound server called PulseAudio however I think Ubuntu Studio will have dropped that with preference for the Jack interface. Either way, if you got some sound out of version 0.9.1 then you should not have immediate problems with either of these sound servers (yet).

      We may run into a couple more things before it all works however I will change the configure process so that it lists libasound as a missing package similarly to the way it lists libx11-dev as unavailable.

      Kind regards, let me know how you get on.

      Nick.

       
    • Graham Wykes

      Graham Wykes - 2009-01-20

      Hi Nick

      The dev files seemed not to be available in the repositories so I went and found debs that matched the installed versions.  They installed ok.  Everything then went smoothly with the installation.

      I can start bristol OK and connect the vkeybd to it with aconnectgui but the sound is woeful.  It sounds like it is being chopped at around 10Hz or so.

      Any ideas?

      Regards
      Graham

       
    • Nick Copeland

      Nick Copeland - 2009-01-20

      Hi Graham,

      Hm, what emulators are you using? Some of them are quite high CPU and if your CPU cannot keep up you get a lot of streaming text output where you started bristol, reporting restarts of the audio device and this will sound chopped. Try starting it with fewer voices for example, or try other filters with the -lwf option (actually this might not work too well anymore, it needs some fixes for a very low output signal). If in doubt start with -vox, this has a very low CPU footprint.

      There is a possibility that it is vkeybd - out of interest, why do you want to use vkeybd, is that for testing or for functionality? Typically you can startBristol, put the mouse into the GUI window and you should be able to play the synth from your qwerty keyboard. Personally I did not think that vkeybd did much more than that. If you cannot play bristol from the GUI with your ASCII keyboard then something is wrong with the default profiles I deliver.

      Anyway, thinking about that led me to another thing: when I implemented the qwerty keyboard tracker for bristol I had a similar issue, ripped sound. It was due to key repeat. When I held down a key I would get endless keyon/keyoff events from the window manager/X11 and these were translated into MIDI note on/off events. My resolution was to disable key repeat when the mouse enters the GUI but you might want to try the following: use the -mididbg to get midi debug output and see if you are getting streams of note on/off events whilst keys are pressed. If you are having this problem with the synths then it may also lead to CPU overload from the event rate and that leads to audio device restarts like the first problem described above.

      Regards,

      Nick.

       
    • Nick Copeland

      Nick Copeland - 2009-01-20

      Just a note: vkeybd does require you disable key repeat otherwise it will generate multiple note on/off events and result in the issue you describe. If you really want to use vkeydb then try 'xset -r' - you can find more about this in http://ccrma.stanford.edu/planetccrma/man/man1/vkeybd.1.html

      As explained, bristol does this automatically for you: it disables key repeat when the mouse enters the GUI and enables it when the mouse leaves the window. I implemented this since I use keyrepeat whilst editing so having it disabled is a royal pain. It's not difficult to code however the author of vkeydb decided not to do so.

      To be honest, unless you have an overriding need for some features of vkeydb you will probably get better results from the bristol GUI. If you do have overriding interest though, or it does not work, then let me know what features you are after and I will implement them sometime or work to fix the problem.

      Kind regards,

      Nick.

       
    • Graham Wykes

      Graham Wykes - 2009-01-21

      Hi Nick

      I wasn't very clear about vkeybd and I'm sorry my lack of clarity has wasted your valuable time.  I only used vkeybd to check that I could get midi into Bristol and it would respond. I don't normally use it.

      The key repeat feature works fine and -mididbg shows it operating correctly.

      One thing that may shed some light on the problem is as follows.

      With Vox running, holding a single note is OK.  Once I hold a second note, the chopping starts.  At the same time, the value for "buffer" in the terminal window keeps changing. 

      This led me to run Memtest and I do have a RAM problem.  I'll get that sorted and then see how I go.

      Regards
      Graham

       
    • Graham Wykes

      Graham Wykes - 2009-01-21

      RAM fixed.  Problem still exists.  I'll try installing 64studio instead and install Bristol into that and see how I go.

      Regards
      Graham

       
    • Nick Copeland

      Nick Copeland - 2009-01-21

      Ok, so you don't get key repeats happening? I had another look at vkeybd and it is apparently 'filtered out' from release 0.11 or so. The onekey/twokey issue is strange with the Vox - have you had a look at the statistics from 'top' in another window whilst running bristol to see if you have a max CPU condition? What kind of PC are you using?

      Regards,

      Nick.

       
    • Graham Wykes

      Graham Wykes - 2009-01-21

      Hi Nick

      CPU max at 16.5% with Vox when I have 3 keys down.  It is a P4 HT 3.4GHz, 1Gb DDR2 RAM in a high end ABIT Mobo.  I have been running it successfully with Puppy Linux using Miditzer under Wine, Linuxsampler and Jconv for convolution reverb.

      I'm reinstalling Studio because it flagged some updates which I let it install and now it seems to have done something to the soundcard because Jack only shows plughw:0 rather than the options it showed before and it won't connect.  So I'll go back to the start and reinstall bristol and the dependencies now that I know what I'm doing - sort of.

      Regards
      Graham

       
    • Graham Wykes

      Graham Wykes - 2009-01-21

      Reinstalled everything, this time with Jack support.  All went to plan and I get the same problem with alsa but Jack works fine.  I'm happy with that for now and I'll play with it for a while.  Could it possibly be the libasound versions are too new?  They are 1.0.17a-0ubuntu4.

      Regards and Thanks
      Graham

       
    • Nick Copeland

      Nick Copeland - 2009-01-21

      I can look to test ALSA 1.0.17, it is quite a lot newer than the ones I currently use.

      Regards, Nick.

       
    • Nick Copeland

      Nick Copeland - 2009-02-22

      Hi Graham,

      I am still waiting to start on the resolution of this issue with the leslie speed, some notes are in the bug report opened against it. I was in the mean time wondering how the 'modwheel' might help you here. The rotation speed actually tracks the modwheel (controller #1) of a synth and I know with some synths (Roland/Edirol) this causes problems because they always return the modwheel to a zero point rather than let them run freelly.

      Regards, Nick.

       
    • Nick Copeland

      Nick Copeland - 2009-03-20

      Hi Graham,

      I have been playing around with the B3 for other reasons, related primarily to adjusting the drawbar and other crosstalk characteristics of the gearbox and the use of the mod wheel to control the speed seems pretty accurate and the spin up/down seems reasonable too. Have you tried this with your keyboard?

      Regards Nick

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks