arp 2600

  • dhudson

    dhudson - 2011-07-27

    hello,  here are a few observations with the 2600.
    when started with jack and midi seq and no other options the synth plays flawless but
    with -nnp option or -voices <n> the synth drops a note or two here and there, and it is more or less random
    when this happens.
    I tried to look at the midi debug data and could not really see the problem , I can see the midi events when it happens.
    so I dont think its midi hardware, not real sure if this is a known problem or just happening here.
    no other software synths or midi have any problems.
    no xruns , cpu ~10% while playing.

    any ideas?


  • Nick Copeland

    Nick Copeland - 2011-10-04

    Hi Dave,

    I missed this submit, not sure why but does not seem to be sending me automated updates - I just came to have a review of the forums.

    What software release are you using - 0.60.8 I imagine, it is the latest code. What about compile time options - do you use any of the the semaphore settings? You might want to try a build with/without -enable-semaphore, these are frowned upon but do change the note allocation code significantly. Also, what hardware are you using - Intel PC hardware?

    I think you probably have a bug but I would be interested in differences with the semaphore. Having said that I was doing some work on the smartphone ports and had to change some of the note logic - perhaps it is time I merged some of the changes back into the mainstream code.

    Kind regards, nick

  • dhudson

    dhudson - 2011-10-22

    hello Nick, I finally got back to this and found your reply.
    I am running ubuntu 11.04 and this said behavior is with the binary package. 0.60.8.
    hardware pc amd dual core 2400mhz 2g-ram emu10k1 soundcard
    I am not sure what the with/ wo semaphore does but I tried to build with -enable-semaphore and
    it died with an error, so I tried it without and it does build but bristol will not run.
    I can reply with logs and debug info here or I can email it if you would rather.

    I may go back to the binary meanwhile…

  • dhudson

    dhudson - 2011-10-22

    ok I tried again and could not build with
    ./configure -disable-semaphore
    but did manage to get it working without
    or just a ./configure and a make clean
    I am starting with
    startBristol -2600 -voices 8 -jack -midi seq
    its now working, still skips notes but dont seem to happen as often.

    many thanks for creating this..btw!


  • Nick Copeland

    Nick Copeland - 2011-10-22

    No, it does not build with -enable-semaphore - have fixed this now but having reviewed some of what was going on I don't think it was directly responsible. In the next release I am going to include some patches that I created for the smartphone stream. There were issues between the note signalling and the envelope states, these are used by the polyphonic code to decide when notes start/end. At high load there was a small window when the midi code would signal 'on' but the envelope would then signal 'off' and the note would be dropped.

    I cannot reproduce your issue on my PC though and you will have to test that code. Perhaps I can post an early release here for you? Another thing you may want to look at is speedstep. Your CPU should not run to 10% for a couple of bristol voices, I would expect 2 to 3%. Try the following:

    grep MHz /proc/cpuinfo

    If it says something other than 2400.00MHz (eg. 800.000MHz) then you have a speed stepping CPU, this is known to cause problems with audio processing. You will need to something like the following as root/sudo:

    cpufreq-selector -g performance -c 0
    cpufreq-selector -g performance -c 1

    The number at the end is for the CPU. Will let you know when I have more code for you to try.

    Kind regards, nick

  • dhudson

    dhudson - 2011-10-22

    you are right about speed stepping.this system does default to on demand 1Ghz.
    Performance, did lower cpu loads to ~3 or 4% and does help note response  , still seems to drop notes when in poly mode.




Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks