can't compile on solaris

2009-04-30
2013-06-05
  • Nobody/Anonymous

    I cannot compile bowtie 0991 on Solaris 10 using gmake 3.80 and gcc  4.2.1. (It compiles fine on Mac OS X 10.5 for me.)

    Any help in getting this to compile would be greatly appreciated.

    Here's the output:

    dsnyder@mollari 15:57:07 bowtie0991 > gmake
    RELEASE_FLAGS =  -xdepend=no
    RELEASE_DEFS =  -DCOMPILER_OPTIONS="-xdepend=no                  "
    EXTRA_FLAGS =
    DEFS =  -DBOWTIE_VERSION="0.9.9.1" -DBUILD_HOST="mollari" -DBUILD_TIME="Thu Apr 30 15:57:24 EDT 2009" -DCOMPILER_VERSION="gcc version 4.2.1 (20081023) (gccfss)" -DBOWTIE_PTHREADS -DBOWTIE_SHARED_MEM -DPREFETCH_LOCALITY=2
    cat ebwt_build.cpp ccnt_lut.cpp hit.cpp ref_read.cpp alphabet.c aligner.h aligner_0mm.h aligner_1mm.h aligner_23mm.h alphabet.h assert_helpers.h binary_sa_search.h bitpack.h bitset.h blockwise_sa.h diff_sample.h ebwt.h ebwt_search_backtrack.h ebwt_search_util.h endian_swap.h filebuf.h formats.h hit.h multikey_qsort.h pat.h qual.h random_source.h range.h range_cache.h range_chaser.h range_source.h ref_aligner.h ref_read.h reference.h rot_buf.h row_chaser.h sequence_io.h spinlock.h str_util.h threading.h timer.h tokenize.h word_io.h zbox.h | cksum | sed 's/[01-9][01-9] .*//' > .bowtie-build.cksum
    /ZoneShared/gccfss4.2.1/gcc/bin/g++ -xdepend=no                  -DCOMPILER_OPTIONS="\"-xdepend=no               \""  -DEBWT_BUILD_HASH=`cat .bowtie-build.cksum` -DBOWTIE_VERSION="\"`cat VERSION`\"" -DBUILD_HOST="\"`hostname`\"" -DBUILD_TIME="\"`date`\"" -DCOMPILER_VERSION="\"`/ZoneShared/gccfss4.2.1/gcc/bin/g++ -v 2>&1 | tail -1`\"" -DBOWTIE_PTHREADS -DBOWTIE_SHARED_MEM -DPREFETCH_LOCALITY=2  -DNDEBUG -Wall -I SeqAn-1.1 -o bowtie-build ebwt_build.cpp ccnt_lut.cpp hit.cpp ref_read.cpp alphabet.c
    g++: 855427: No such file or directory
    ebwt_build.cpp:361: warning: deprecated conversion from string constant to 'char*'
    [... more of the same warnings, then]
    gmake: *** [bowtie-build] Error 1
    dsnyder@mollari 15:58:26 bowtie0991
    ******************

    Dean A.Snyder
    Senior Programmer Analyst
    Center for Inherited Disease Research
    Johns Hopkins School of Medicine

     
    • Ben Langmead

      Ben Langmead - 2009-04-30

      Hello Dean,

      I also saw that issue when I tried on compile on Solaris recently.  I've fixed it in the trunk and the next release of Bowtie will contain the fix.  Please check back for 0.9.9.3 in the near future (perhaps at the end of next week).

      Thanks,
      Ben

       
    • Nobody/Anonymous

      Great!

      If it's not too much work for you, I'd be interested in knowing what the problem was.

      Thanks.

       
    • Nobody/Anonymous

      Any news on when the trunk fixes being incorporated in 0.9.9.3 will be available?

       
      • Ben Langmead

        Ben Langmead - 2009-05-19

        At the next release - in a few weeks or so.  Do you have an issue with 0.9.9.3?  Is it not compiling on Solaris?  I can compile it on Solaris 10 just fine.  Here are details about the machine I compiled it on:

        loompa $ uname -a
        SunOS loompa 5.10 Generic_125100-10 sun4u sparc SUNW,Sun-Fire-V210
        loompa $ g++ -v
        Using built-in specs.
        Target: sparc-sun-solaris2.10
        Configured with: ../gcc-4.1.2/configure --prefix=/usr/local/gcc-4.1.2
        Thread model: posix
        gcc version 4.1.2

        Ben

         

Log in to post a comment.