Daniela Radu - 2013-04-22

Hi there,

The project on which I'm working used boost library version 1_46_1 just fine only with a few warnings.

At some point I tried upgrading it to a later version (I tried 1_53 down to 1_51) but I keep getting the following errors:

c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : warning C4002: too many actual parameters for macro 'round'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : error C2027: use of undefined type 'T'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : error C2226: syntax error : unexpected type 'T'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : error C2143: syntax error : missing ';' before '+'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : error C2059: syntax error : ')'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : error C2059: syntax error : ')'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(43) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(43) : error C2374: 'boost::math::floor' : redefinition; multiple initialization
        c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(41) : see declaration of 'boost::math::floor'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(43) : error C2143: syntax error : missing ';' before '+'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(43) : error C2059: syntax error : ')'
c:\program files\boost_1_51_0\boost\math\special_functions\detail\round_fwd.hpp(43) : error C2059: syntax error : ')'

So, I will stick to 1.46.1 for the moment, but I hope this feedback helps improving this great library!

Best,
Daniela