error checking for libXext while compiling

Help
Cedric
2005-05-26
2013-04-29
  • Cedric
    Cedric
    2005-05-26

    i've no luck trying this prog :(

    - runtime error on my windows station ..

    - not better on my linux server :

    ./configure --x-includes=/usr/X11R6/include --x-libraries=/usr/X11R6/lib

    (...)
    checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
    checking for IceConnectionNumber in -lICE... no
    checking for libXext... no
    configure: error: We need a working libXext to proceed. Since configure
    can't find it itself, we stop here assuming that make wouldn't find
    them either.

    this is where i find libXext* on my mandrake 10.1 :

    /usr/X11R6/lib/libXext.so.6
    /usr/X11R6/lib/libXext.so.6.4

    I am new to linux , can anyone help please ?

     
    • Ken Schenke
      Ken Schenke
      2005-06-09

      I'm not sure why configure would have trouble finding the libXext libraries, or even why you would need to specify the --x-includes and --x-libraries options.  Have you tried configure without any options?

      As far as the Windows version goes, I assume you're using a non-English version of Windows?  This is a known problem, and one for which I have fixed.  I need to get a new version out in the next few weeks that would make this fix available for everyone.

       
    • Cedric
      Cedric
      2005-06-27

      Thanks for your reply

      if i d'ont specify the --x-includes & --x-librairies it stops with an error saying it doesn't find them on the line ''checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include ''

      you're right , i'm using a French versions of Windows..

      I hope you'll be able to release this fixed version asap ;p

      regards

      Cdric