Question about OGG encoding

2013-11-29
2015-03-14
  • AX Redneck 34noff

    Hello!
    How do You achieve such high quality/bitrate factor of Vorbis encoding? XCFA and others produce more tin-pan sound with the same size of output files.


    Your ax "Redneck" 34noff

     
  • Robert Kausch

    Robert Kausch - 2013-11-29

    I think the deciding difference could be that fre:ac sets the quality parameter by default when encoding Vorbis while XCFA always sets the bitrate directly.

    Setting the quality value puts the encoder in VBR (variable bitrate) mode and leaves it more room for optimizations. Setting the target bitrate enforces ABR (average bitrate) mode with stricter constraints and less potential for optimizations leading to slightly worse sound quality.

    Additionally, on Windows and OS X, fre:ac uses the aoTuV Vorbis encoder which is optimized for quality especially at lower bitrates. It should produce slightly better quality audio files than the official Xiph.org Vorbis encoder.

    On Linux, however, fre:ac uses the Vorbis encoder installed on your system. That might be either aoTuV or the Xiph.org encoder depending on your distribution. In any case, it would be the same one XCFA uses on the same computer, so the only difference should be VBR vs. ABR mode there.

     
  • AX Redneck 34noff

    Thank You! I'll try aoTuV encoder...
    p.s. I set not "bitrate" but "quality" in XCFA, maybe it uses ABR in "quality" mode too...

     
  • Robert Kausch

    Robert Kausch - 2013-12-01

    Ok, I was looking at the XCFA source code and was mistaken, because the corresponding variable is called PtrStrBitrate. But digging deeper I see that it can contain either a --bitrate or a --quality option.

    The only relevant difference should be aoTuV vs. Xiph.org encoder then.

     
  • AX Redneck 34noff

    Seems like XCFA passes bitrate to encoder even if i choose quality. Thanks again!

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks