This change of version_id isn't enough because Bochs will still emulate "non-existing on P5" xAPIC LVT entries. The APIC emulation should be hacked too.

Stanislav