Designer Button? (Vy dumb question)

Help
2004-10-14
2013-05-01
  • DTTS Microwave Society

    Utter newbie problem. Under

    Python 2.3
    wxPython 2.4.1.2
    Boa Constructor 0.3.1 (or 0.3.0 or 0.2.3, tried them all)
    SuSE 9.0

    nothing resembling the Designer Button shows up in the Editor pallette or anywhere else. What's happening?

    Thanks
    Frank

     
    • Werner F. Bruhin

      Here is a newsgroup which is helpful too:
      gmane.comp.ide.boa-constructor.user

      Just recently discussed there:

      Hi Pan,

      Pan wrote:

      > Hi,
      > I am testing Boa on my Mandrake linux (10.0). After the installation I tried to follow the help file but it seems that the major component "designer" is no where to be found. (there's no icon for me to click to show it).  
      >

      I've read all the replies in this thread and I am just as baffled as
      all the others that replied.

      The only thing I can think of is that you may not be aware that Boa's
      menus and toolbar is dependent on the currently active file in the Editor.

      So e.g. if you have a new wxFrame module as the active file, the Designer
      should be available via File->Frame Designer, the Designer toolbar button
      or by pressing F12.

      I have no other ideas, sorry,
      Riaan.

      See you
      Werner

       
      • DTTS Microwave Society

        Bingo! Many thanks for the pointer, and especially for the quick response.

        Frank

         
    • jasonlazar

      jasonlazar - 2004-11-19

      I found the same problem and it is because the

      #Boa:Frame:wxFrame1

      string must be at the top of the file -- (wxFrame1 would be whatever name you gave to your wxFrame).  If you put this string back when Boa is open you must exit and restart Boa to get the Designer button back.

      I don't remember deleting the string from my file but I must have with out thinking it was required to be there.

      To check if there are other problems with the files format, just add another wxFrame and see if the Designer button comes up for the new file.  If it does your know there is something wrong with your file.  Compare the files to see what is wrong.

      Jason

       

Log in to post a comment.