Import uuid fails...

Help
2008-03-22
2013-05-01
  • phil someone

    phil someone - 2008-03-22

    i needed to generate a uuid for my program, but when i ran import uuid it didn't find the module.
    i have python 2.5 and importing the module uuid works fine in IDLE... wierd.

     
    • Werner F. Bruhin

      Just tried it on my system and I don't have a problem.

      # Python 2.5 (r25:51908, Sep 19 2006, 09:52:17) [MSC v.1310 32 bit (Intel)]
      # wxPython 2.8.7.1, Boa Constructor 0.6.1
      # Type "copyright", "credits" or "license" for more information.
      >>> import uuid
      >>> uuid.ctypes()
        File "<console>", line 1, in <module>
      ''' <type 'exceptions.TypeError'> : 'module' object is not callable '''
      >>> uuid.ctypes
      <module 'ctypes' from 'C:\Python25\lib\ctypes\__init__.pyc'>

      Can you give more details on your install.

      Werner

       
      • phil someone

        phil someone - 2008-03-22

        well i have boa 0.6.1 and i found that "import uuid" only fails in the shell, because it worked fine in a test module. so it's not really a problem for me. if it works for you then i don't think it's anything to worry about.

         
        • Werner F. Bruhin

          Are you using the .exe install of Boa?  If yes, you might want to switch using the source release (or get the latest from cvs).

          With the .exe install Boa will only find things which were used when the .exe was created.

          Best regards
          Werner

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks