error: global 'string' not defined

2003-02-20
2003-02-25
  • Luke McCarthy

    Luke McCarthy - 2003-02-20

    I seem to be having a little trouble starting Boa. I get the splash screen and a message box saying "global 'string' not defined".

    Did I miss something blindingly obvious?

    It looks really cool but I can't get it to start. I have been writing wxPython apps in other Python IDEs but they crash constantly.

     
    • Anonymous - 2003-02-20

      I have seen errors like this when I tried to use Boa 0.1.3a on WinXP using wxPython 1.4.

      I have a feeling that it may be triggered by the new version of wxPython, because I didn't see this problem in wxPython 1.3.  This may have been fixed in Boa 0.1.4 or 0.2.1.  I haven't checked.

      Boa seemed to complain in about 5 different source files.  If you check the error's details to find the filenames, you can add an "import string" to the top (near the other imports or 'from' statements) of each file it complains about.  As you try to run Boa after each change, it will complain about the next file, so that you can update that one too, until Boa stops complaining.

      It seems to work ok after that, but I don't use Boa heavily.  I have no idea if these changes will be made to the official Boa source.  Maybe they just haven't tried the new wxPython yet, or maybe you need to d/l the latest CVS source.

       
    • Anonymous - 2003-02-25

      I had similiar problems after installing new Boa and wxPython. It seemed like Boa assumed that "wxPython.wx" had 'import string' in it, so I added importing into beginning of wx.py file (only there) and everything seems to work so far.

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks