Major Bug

  • Gerard van Doorn

    I installed from Ubuntu repository and, while this seems a very powerful tool, cannot use the menu 'Open' option to load a file. When Open is selected in the editor the whole app just shuts down. I can open a file by browsing there in explorer and double clicking but it does seem a tad unfriendly when you use the approved method to open a file and get turfed out!

    • Werner F. Bruhin

      What version is in the Ubuntu repository?

      If it is NOT 0.6.1 the I suggest to get 0.6.1 from sourceforge.

      If it is 0.6.1 are you getting any error/traceback?

      If it is 0.6.1. I will try to have a look at it on my Ubuntu install and see if I can help.


      • Gerard van Doorn

        It is 0.6.1. There is no error message - the app just closes in the same way it would if I selected the exit option. To be fair, this could have something to do with a recent upgrade to Ubuntu 8.04 or the recent Gnome upgrade (I just accept the software upgrades when they are presented to me) - I don't recall this behaviour under Gutsy.


        • Werner F. Bruhin

          I am still only testing Ubuntu, and I am on 7.x.

          Can you run it with the -T switch, which should generate a trace file.  IIRC on the next start of Boa it will parse this trace file for any tracebacks.

          BTW, how is one adding a switch to a desktop item on Gnome/Ubuntu?


          • Gerard van Doorn

            Here is what was output when I ran "boa-constructor" in a terminal:
            Starting Boa Constructor v0.6.1
            importing wxPython
            reading user preferences
            running main...
            importing Models.Controllers
            importing Models.EditorModels
            importing Views
            importing Views.SourceViews
            importing Explorers.ExplorerNodes
            importing Companions
            importing PropertyEditors
            importing Companions.FrameCompanions
            importing Companions.WizardCompanions
            importing Companions.ContainerCompanions
            importing Companions.SizerCompanions
            importing Companions.BasicCompanions
            importing Companions.ButtonCompanions
            importing Companions.ListCompanions
            importing Companions.GizmoCompanion
            importing Companions.LibCompanions
            importing Companions.UtilCompanions
            importing Companions.DialogCompanions
            importing ZopeLib.ZopeCompanions
            importing Models.PythonControllers
            importing Models.PythonEditorModels
            importing Views.AppViews
            importing Views.PySourceView
            importing Views.ProfileView
            importing Views.OGLViews
            importing Explorers.FileExplorer
            importing Models.wxPythonControllers
            importing Models.wxPythonEditorModels
            importing Views.Designer
            importing Views.InspectableViews
            importing Views.CollectionEdit
            importing Views.DataView
            importing Views.SizersView
            importing Models.ConfigSupport
            importing Models.CPPSupport
            importing Models.HTMLSupport
            importing Models.XMLSupport
            importing ZopeLib.ZopeEditorModels
            executing plug-ins...
            executing CodeTemplates.plug-in
            executing FormatParagraph.plug-in
            executing ModuleFinder.plug-in
            executing HelpBook.plug-in
            importing Explorers
            executing RegexEditor.plug-in
            executing ImageEditor.plug-in
            executing SVNSupport.plug-in
            executing PyInterpreterChooser.plug-in
            creating Palette
            importing Palette
            creating Inspector
            importing Inspector
            creating Editor
            importing Editor
            importing Explorers.PrefsExplorer
            importing Explorers.CVSExplorer
            importing Explorers.ZipExplorer
            importing Explorers.FTPExplorer
            importing Explorers.DAVExplorer
            importing Explorers.SSHExplorer
            importing ZopeLib.ZopeExplorer
            importing ZopeLib.ZopeViews
            showing main frames

            ** (python:6609): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed

            ** (python:6609): CRITICAL **: clearlooks_style_draw_box_gap: assertion `height >= -1' failed
            *** glibc detected *** python: double free or corruption (out): 0x094c6660 ***
            ======= Backtrace: =========
            ======= Memory map: ========
            08048000-08140000 r-xp 00000000 08:02 1427876    /usr/bin/python2.5
            08140000-08165000 rw-p 000f7000 08:02 1427876    /usr/bin/python2.5
            08165000-09ef5000 rw-p 08165000 00:00 0          [heap]
            b4900000-b4921000 rw-p b4900000 00:00 0
            b4921000-b4a00000 ---p b4921000 00:00 0
            b4a71000-b4ad1000 rw-s 00000000 00:09 40960041   /SYSV00000000 (deleted)
            b4ad1000-b4ad2000 ---p b4ad1000 00:00 0
            b4ad2000-b52d2000 rw-p b4ad2000 00:00 0
            b52d2000-b52e6000 r--p 00000000 08:02 1721445    /usr/share/fonts/type1/gsfonts/n019003l.pfb
            b52e6000-b52ff000 r--p 00000000 08:02 1721461    /usr/share/fonts/type1/gsfonts/n022004l.pfb
            b52ff000-b5317000 r--p 00000000 08:02 1721460    /usr/share/fonts/type1/gsfonts/n022003l.pfb
            b5317000-b53a8000 r--p 00000000 08:02 1754168    /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
            b53a8000-b53db000 r-xp 00000000 08:02 1607794    /usr/lib/python2.5/lib-dynload/
            b53db000-b53de000 rw-p 00033000 08:02 1607794    /usr/lib/python2.5/lib-dynload/
            b53de000-b53e0000 r-xp 00000000 08:02 1605840    /usr/lib/python2.5/lib-dynload/
            b53e0000-b53e1000 rw-p 00001000 08:02 1605840    /usr/lib/python2.5/lib-dynload/
            b53e1000-b53e4000 rw-s 00000000 00:09 28835880   /SYSV00000000 (deleted)
            b53e4000-b53e8000 r-xp 00000000 08:02 1605861    /usr/lib/python2.5/lib-dynload/
            b53e8000-b53e9000 rw-p 00004000 08:02 1605861    /usr/lib/python2.5/lib-dynload/
            b53e9000-b5418000 r-xp 00000000 08:02 1428166    /usr/lib/
            b5418000-b541c000 rw-p 0002e000 08:02 1428166    /usr/lib/
            b541c000-b542d000 r-xp 00000000 08:02 1607774    /usr/lib/python2.5/lib-dynload/
            b542d000-b542e000 rw-p 00010000 08:02 1607774    /usr/lib/python2.5/lib-dynload/
            b542e000-b542f000 r-xp 00000000 08:02 1607760    /usr/lib/python2.5/lib-dynload/
            b542f000-b5430000 rw-p 00000000 08:02 1607760    /usr/lib/python2.5/lib-dynload/
            b5430000-b548d000 r-xp 00000000 08:02 2213886    /usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/
            b548d000-b5495000 rw-p 0005d000 08:02 2213886    /usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/
            b5495000-b5496000 rw-p b5495000 00:00 0
            b5496000-b550a000 r-xp 00000000 08:02 2213891    /usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/
            b550a000-b5512000 rw-p 00073000 08:02 2213891    /usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/
            b5512000-b5527000 r-xp 00000000 08:02 2213835    /usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/
            b5527000-b552a000 rw-p 00015000 08:02 2213835    /usr/lib/python2.5/site-packages/wx-2.6-gtk2-unicode/wx/
            b552a000-b5539000 r-xp 00000000 08:02 1428160    /usr/lib/
            b5539000-b553a000 rw-p 0000e000 08:02 1428160    /usr/lib/
            b553a000-b56bb000 rw-p b553a000 00:00 0
            b56bb000-b57e5000 r-xp 00000000 08:02 1490977    /usr/lib/i686/cmov/
            b57e5000-b57fa000 rw-p 00129000 08:02 1490977    /usr/lib/i686/cmov/
            b57fa000-b57fd000 rw-p b57fa000 00:00 0
            b57fd000-b583b000 r-xp 00000000 08:02 1490992    /usr/lib/i686/cmov/
            b583b000-b583f000 rw-p 0003d000 08:02 1490992    /usr/lib/i686/cmov/
            b5840000-b5843000 r-xp 00000000 08:02 1607770    /usr/lib/python2.5/lib-dynload/
            b5843000-b5844000 rw-p 00003000 08:02 1607770    /usr/lib/python2.5/lib-dynload/
            b5844000-b5849000 r-xp 00000000 08:02 1605818    /usr/lib/python2.5/lib-dynload/
            b5849000-b584a000 rw-p 00005000 08:02 1605818    /usr/lib/python2.5/lib-dynload/
            b584a000-b584d000 r-xp 00000000 08:02 1605849    /usr/lib/python2.5/lib-dynload/
            b584d000-b584e000 rw-p 00002000 08:02 1605849    /usr/lib/python2.5/lib-dynload/
            b584e000-b5852000 r-xp 00000000 08:02 1607763    /usr/lib/python2.5/lib-dynload/
            b5852000-b5853000 rw-p 00004000 08:02 1607763    /usr/lib/python2.5/lib-dynload/
            b5853000-b585e000 r-xp 00000000 08:02 1605810    /usr/lib/python2.5/lib-dynload/
            b585e000-b5861000 rw-p 0000a000 08:02 1605810    /usr/lib/python2.5/lib-dynload/
            b5861000-b5864000 r-xp 00000000 08:02 1605844    /usr/lib/python2.5/lib-dynload/
            b5864000-b5865000 rw-p 00002000 08:02 1605844    /usr/lib/python2.5/lib-dynload/
            b5865000-b5866000 ---p b5865000 00:00 0
            b5866000-b6066000 rw-p b5866000 00:00 0
            b6066000-b60ed000 r--p 00000000 08:02 1754169    /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
            b60ed000-b616a000 r--p 00000000 08:02 1754174    /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-Bold.ttf
            b616a000-b61ea000 r--p 00000000 08:02 1754177    /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed.ttf
            b61ea000-b624a000 rw-s 00000000 00:09 28639263   /SYSV00000000 (deleted)
            b624a000-b6250000 r-xp 00000000 08:02 1425575    /usr/lib/
            b6250000-b6251000 rw-p 00006000 08:02 1425575    /usr/lib/
            b6251000-b6280000 r-xp 00000000 /usr/bin/boa-constructor: line 3:  6609 Aborted                 python /usr/share/boa-constructor/

            The portion of the output stream from "*** glibc detected *** python: double free or corruption (out): 0x094c6660 ***" is what was output after I selected File>Open from the menu. Does this help?

            • Werner F. Bruhin

              I can't read all this, but I noticed that you are on wxPython 2.6, which is pretty old, I would even say very old.

              2.8.8 is just about coming out.  There was a small issue with 2.8.7 and gridbagsizer support which caused problems in Boa's designer, but 2.8.4 worked well for me (on Vista), I am currently using the preview for 2.8.8 and it looks good so far.

              On my Ubuntu machine I have wxPython and I don't see any problems, but then I do not use that box that often - at least not yet.


    • Jurgis Pralgauskis

      I try to checkout cvs using sf given instructions

      but it doesn't work (cvs seems not to like empty anonymous password)
      cvs login

      just does nothing :/

      • Werner F. Bruhin

        I do not know why sourceforge shows the first line, it just does the login and I just tried it out it does not seem to be necessary.

        I.e. while I write this I am checking it out on my Ubuntu test machine with:

        cvs co -P boa



Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks