can't get boa started

2007-07-07
2013-05-01
  • Peter Galfi

    Peter Galfi - 2007-07-07

    Hi all,

    I installed boa constructor 0.6.1, but I can't get the program started. I tried all kind of versions of wxPython and Python by now from 2.3 to 2.5 (with the appropriate wxPython versions), but it always ends with the same error:

    ImportError: MemoryLoadLibrary failed loading wx\_core_.pyd

    It should be something basic, but I can't figure it out.

    Peter

     
    • Barton Cline

      Barton Cline - 2007-07-08

      Is that a typo, or am I missing something? Instructions for getting 0.5.1 from the CVS are in the thread entitled "compatibility with wxPython 2.7.1.3?" in the Help Forum (under the "Forums" tab above. It works great with version 2.8.x of wx. (I'm using 2.4.4 of python)

       
      • Chelonian

        Chelonian - 2007-07-10

        Barton, Boa 0.6.1. has been released.  I read the announcement on the wxPython mailing list, a message dated Jul 5 2007 by Riaan Boysen; here is an archived link to it:

        http://aspn.activestate.com/ASPN/Mail/Message/wxPython-users/3520310

        In that message Riaan indicated 0.6.1 can be gotten here:

        http://sourceforge.net/project/showfiles.php?group_id=1909&package_id=1856&release_id=521108

        I've just begun fooling around with it (it did load fine on my computer, WinXP, Python 2.5 and wxPython 2.8.4.0).  I'm not sure what the problem is regarding the MemoryLoadLibrary failure as galfip mentioned, though I have had problems like that on my older machines and it was due to a missing .dll file perhaps, and is true for many wxPython programs.  If I figure out more about how to fix it I'll get back here with that.  In the meantime if you just Google that error you'll find other people addressing that problem generally with wxPython. 

        Che

         
        • Barton Cline

          Barton Cline - 2007-07-15

          Thanks, Che. I updated from CVS. I was a bit nervous, changing the IDE in the middle of a big project, but all went well after a system re-boot. (I initially had a problem with Designer not knowing how to display frames, etc the correct size)

           
    • IloChab

      IloChab - 2007-11-20

      I had the same problem on a fresh windows 2000 installation.
      I solved it following this tip:

      http://forum.opensubtitles.org/viewtopic.php?t=881

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks