• Paul Robinson

    Paul Robinson - 2008-04-11

    Hi guys...

    This is really quite a kewl little program. Got it working with kde on f8 today... i cant find a "proximity" command thats appropriate, but i've set mine with the following commands:

    lock: dcop kdesktop KScreensaverIface lock
    unlock: killall -9 kdesktop_lock

    • Frédéric Nass

      Frédéric Nass - 2008-09-12

      Hi all,

      If you use KDE4, I recommand you use the following commands, as D-COP server was replaced with D-BUS within KDE4 :

      lock : qdbus org.kde.screensaver /ScreenSaver Lock ; xset dpms force off
      unlock : xset dpms force on ; killall -9 krunner_lock

      xset dpms force on/off is used to shutdown/wake up the monitor, so you don't have to wake it up moving your mouse.

      It works like a charm. :-)

      Thanx for this incredible tool.


    • Frédéric Nass

      Frédéric Nass - 2008-09-12


      unlock : xset dpms force on ; killall -9 krunner_lock kblankscrn.kss

  • theillien

    theillien - 2009-11-20

    I got this half working. I used the commands provided but only locking works. When I bring my phone back into range my workstation doesn't unlock.  Additionally, what exactly is the Proximity command and what should be used. Right now it still says 'xscreensaver-command -p' but a) looking at the xscreensaver-command help doesn't list a -p option and b) because I use the KDE screensaver I'm not running xscreensaver to apply commands to. Any help on this would be appreciated.


  • ybdjkfd

    ybdjkfd - 2013-05-16

    The following works for me in KDE 4.10:

    • Lock: qdbus org.freedesktop.ScreenSaver /ScreenSaver Lock
    • Unlock: qdbus | grep kscreenlocker_greet | xargs -I {} qdbus {} /MainApplication quit
    • Proximity: qdbus org.freedesktop.ScreenSaver /ScreenSaver SimulateUserActivity

    See https://bugs.kde.org/show_bug.cgi?id=314989#c3 .

    Last edit: ybdjkfd 2013-05-16

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks