#11 No module named validate

closed-duplicate
None
7
2007-09-02
2007-08-27
Thorsten
No

Starting start_proximity yields in

bob:~/blueproximity-1.1.5 # ./start_proximity.sh
['/usr/lib/python2.5/configobj.py']
(2, 5, 0, 'final', 0)
2.5 (r25:51908, May 25 2007, 16:14:04)
[GCC 4.1.2 20061115 (prerelease) (SUSE Linux)]
Traceback (most recent call last):
File "proximity.py", line 37, in <module>
from validate import Validator
ImportError: No module named validate

Discussion

  • Thorsten

    Thorsten - 2007-08-27
    • priority: 5 --> 7
     
  • Lars Friedrichs

    Lars Friedrichs - 2007-08-27

    Logged In: YES
    user_id=114903
    Originator: NO

    The Validate Object should be part of python-configobj. Please check if it is there. Btw, you should use a more uptodate version like 1.1.8. because 1.1.5 has a nasty not saving changed settings bug.

     
  • Lars Friedrichs

    Lars Friedrichs - 2007-08-27
    • assigned_to: nobody --> highno
    • status: open --> pending
     
  • Lars Friedrichs

    Lars Friedrichs - 2007-08-27

    Logged In: YES
    user_id=114903
    Originator: NO

    This is a duplicate of bug #1782347 which is already fixed.

     
  • Lars Friedrichs

    Lars Friedrichs - 2007-08-27
    • status: pending --> closed-duplicate
     
  • Thorsten

    Thorsten - 2007-09-01
    • status: closed-duplicate --> open-duplicate
     
  • Thorsten

    Thorsten - 2007-09-01

    Logged In: YES
    user_id=1692926
    Originator: YES

    OK, this is the wrong place but I have to say this is the most exciting idea in OpenSource I ever heard. I'll tell my friends to kick their Windows where they have to authenticate using their fingerprints - that is hindering :)

    Can you patch your code so that it says "you need the blahblah module" instead of above error msg ?

     
  • Thorsten

    Thorsten - 2007-09-01

    Logged In: YES
    user_id=1692926
    Originator: YES

    OK, this is the wrong place but I have to say this is the most exciting idea in OpenSource I ever heard. I'll tell my friends to kick their Windows where they have to authenticate using their fingerprints - that is hindering :)

    Can you patch your code so that it says "you need the blahblah module" instead of above error msg ?

     
  • Thorsten

    Thorsten - 2007-09-01
    • status: open-duplicate --> closed-duplicate
     
  • Thorsten

    Thorsten - 2007-09-01

    Logged In: YES
    user_id=1692926
    Originator: YES

    How can I install python-configobj ? I cannot find it for SUSE and I do not get it when compiling python from source from www.python.org ?

    thanks in advance!

     
  • Thorsten

    Thorsten - 2007-09-01
    • status: closed-duplicate --> open-duplicate
     
  • Lars Friedrichs

    Lars Friedrichs - 2007-09-01

    Logged In: YES
    user_id=114903
    Originator: NO

    This is the homepage of the configobj project: http://www.voidspace.org.uk/python/configobj.html
    It tells how to install. Please note that you will need both configobj and validation modules.

    I will think about the note on the missing extensions. That should not be too hard.

     
  • Lars Friedrichs

    Lars Friedrichs - 2007-09-02
    • status: open-duplicate --> closed-duplicate
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks