I have recently been playing with the ZakLineObject and notice that if I try to set the channel to 0, I get the error "Zak channel must be an integer greater than zero". But zak channels start counting from 0, so I think it should be "greater than or equal to zero".
The other thing about that object is, they're really zk channels, not "zak" channels. Naming is tricky, because you want to show it's using the zak system, but I think that the table heading in the SoundObject editor for ZakLineObject should say "Zk Channel" instead of "Zak Channel". I think renaming the object "ZkLineObject" would also be good, but I can see why you might want to keep "Zak" in the name.