Blat 1.8.2 character sets

  • labbywolf

    labbywolf - 2004-09-22

    Howdy all,

    I'm using a relatively geriatric version of blat - 1.8.2 - I know that I'm well behind the curve, but I've been using this version for some time and don't want to upgrade it if at all possible.

    We're using blat for notifications to email and pagers (Nextel phones to which you can send e-mail messages) - there's a weird problem though.  I built out a new box, using this old copy of blat, and messages being sent to my email look great, but messages sent to my pager have a lot of ISO-8859-1 artifacts in there (e.g. the spaces are turned into "=20", etc.) 

    Is there any way to force blat to use a certain character set in command-line mailings?  I have another box, same OS, same version of blat which is sending things in ASCII without issue.

    Thanks in advance for any help.


    • Chip

      Chip - 2004-12-19

      Look to your server settings.  When the same version of Blat is acting differently, and it uses all the same command line options, then something else has changed.  Specifically, your server on the new box.  If you have not already figured out the problem and a solution, try creating an exact image of the functional server's drive and put it on another box to see if the problem returns.


      • Abbra

        Abbra - 2007-03-12

        please list available -charset for blat 2.6.1

        • Chip

          Chip - 2007-03-20

          Available character sets?  Use whatever you need.  Blat does not have any character sets built into it.

          • Abbra

            Abbra - 2007-03-20

            I understand that.
            The problem is a letter send by blat displays in Outllok 2003 in KOI8-R (russian)
            but original charset of message is windows-1251
            What can i write in command line in Blat key "-charset ..." to make the Outlook 2003 show message in true original character set (win-1251)?
            Thank You.

            • Chip

              Chip - 2007-03-23

              Did you try -charset "win-1251" ?

              • Abbra

                Abbra - 2007-03-26

                Yes I tried ( -charset "win-1251" ) - it does not work (MS Outlook 2003 choose wrong charset for displaying message), but ( -charset Windows-1251 ) is working fine. Thank You for support.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks