bad substitution, during bootstrap

Help
2008-12-24
2013-04-26
  • Lars Huttar

    Lars Huttar - 2008-12-24

    Hi, I'm having trouble building Stylus using bootstrap.

    First, when going through the README, I had trouble figuring out how to fulfill the “xmllib2″ requirement , but eventually inferred that xmllib is a synonym for libxml. It would probably be helpful to put "a.k.a. libxml2" in there, since the referenced web site, xmlsoft.org, calls it libxml2, and libxml2 seems to be the standard name for linux packages for this library.
    You may also want to put "automake" into the bulleted list of EXTERNAL REQUIREMENTS.

    Then when running bootstrap, I got an error saying “macro `AM_PATH_XML2′ not found in library”, which I’m told (http://osdir.com/ml/finance.quickfix.user/2007-01/msg00003.html) means I need libxml2-dev.

    After installing libxml2-dev, that error is gone, but I still get “./bootstrap: 119: Bad substitution”.
    Strange, because line 119 of bootstrap is "fi".
    The preceding line is "automake --foreign --add-missing".

    And there I’m stuck. Any help would be appreciated.

     
    • Lars Huttar

      Lars Huttar - 2008-12-24

      Forgot to say, I'm running Ubuntu 8.10.

       
      • Brendan

        Brendan - 2008-12-27

        Generally, we don't claim to be experts in automake (which, while it eases some aspects of building on various Unix flavors, has its own issues). We have built successfully on Redhat and Debian. I don't recall if we've tried Ubuntu. I suspect the problem is a version issue around automake and autoconf.

        Since bootstrap is just a shell script that encapsulates the steps, it would be interesting for your to try to run each step, in order, by hand to see what errors (if any) you get. The lines of interest begin at about 114. Let me know what happens.

         

Log in to post a comment.