Build errors with bigloo-lib-0.19

Help
2003-10-04
2003-10-10
  • Grzegorz Chrupala

    Hi,
    I am trying to build bigloo-lib-0.19 with bigloo 2.6a on Mandrake Linux 9.1.
    When I run make first I get a lot of warnings of this type:
    *** WARNING:bigloo:(@ filter __r4_control_features_6_9)
    Variable overridden by -- (@ filter srfi-1)

    And finally make aborts with the following message:
    File "./misc.scm", line 229, character 7689:
    #  ((regular-grammar
    #  ^
    # *** ERROR:bigloo:string-blank?
    # wrong number of argument -- ((lambda (input-port proc) (begin (letrec (( ...
    make[2]: *** [misc.c] Error 255
    make[2]: Leaving directory `/home/grzegorz/tmp/bigloo-lib-0.19/common'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/grzegorz/tmp/bigloo-lib-0.19'
    make: *** [all-recursive-am] Error 2

    Any fixes? Do I need a previous version of Bigloo?

    Thanks!
    Greg.

     
    • Vladimir V. Tsichevski

      This version (0.19) of bigloo-lib is not compatioble with Bigloo 2.6a. Please, get the latest version if bigloo-lib from CVS.

       
      • Grzegorz Chrupala

        I tried. But I must be doing something wrong:

        [grzegorz@privadas grzegorz]$ cvs -d:pserver:anonymous@cvs.sourceforge.net:/cvsroot/bigloo-lib login
        Logging in to :pserver:anonymous@cvs.sourceforge.net:2401/cvsroot/bigloo-lib
        CVS password:
        cvs [login aborted]: end of file from server (consult above messages if any)

         
        • Vladimir V. Tsichevski

          CVS at SF (anonymous access thru pserver) seemed to be down this week. Try again today

           

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks