#24 bigloo-lib does not build with bigloo 2.6a

closed-accepted
None
8
2006-01-21
2006-01-02
No

1) configure.in rejects 2.6 and also has a stray ';' in
the ldap libs.
The attached patch fixes this problem

2) Build fails while compiling common/time.scm:
bigloo -I . -L . -afile .afile -cgen time.scm
-o time.c
time.scm:

*** WARNING:bigloo:(@ current-seconds __date)
Variable overridden by -- (@ current-seconds time)

*** WARNING:bigloo:(@ fprintf __r4_output_6_10_3)
Variable overridden by -- (@ fprintf format)

*** WARNING:bigloo:(@ printf __r4_output_6_10_3)
Variable overridden by -- (@ printf format)

*** WARNING:bigloo:(@ format __r4_output_6_10_3)
Variable overridden by -- (@ format format)

File "./time.scm", line 287, character 7303:
# (set! second
#t))
# ^
# *** ERROR:bigloo:loop
# wrong number of argument -- ((lambda (input-port
proc) (begin (letrec (( ...

Discussion

  • Dimitris Vyzovitis

    • priority: 5 --> 8
     
  • Vladimir V. Tsichevski

    Logged In: YES
    user_id=19072

    bigloo-lib-0.21 should be compiled with bigloo2.6e or
    bigloo2.6f.

     
  • Vladimir V. Tsichevski

    • assigned_to: nobody --> wowa
    • status: open --> closed-accepted
     

Log in to post a comment.