Menu ▾ ▴

#4 betsie authorisation

open
nobody
None
5
2004-04-08
2004-04-08
Anonymous
No

I have noticed a problem when I get to a betsie
authorisation page. If certain conditions (below) are
met, betsie denies me access by jumping back to the
login screen.

It only happens when the total length of the username
or password = 14 ?

eg username = 8 and password = 6 characters. = 14

also a pattern develops

5 + 6 = 11

11 + 6 = 17

a pattern of + 3 at guess the next one is 20

it works if I have and username of length 7 or 9 and
password remains 6

or if username is of length 8 and password = 7 or 8

Is this a bug ?

I am using ldap authentication and it works fine when
not using betsie but with some users who have a
username and password with a total lengh of 14 it goes
back to the login page. In the apache logs it shows 401
397 error code

Is someone able to help me on this? has anyone else
come across it before? manythanks in advance

Discussion


Log in to post a comment.