SourceForge has been redesigned. Learn more.

Mouse frozen, No full screen @ 8 bit-OSX 10.4

  • Richard Piotter

    Richard Piotter - 2008-05-23

    I got Basilisk to finally boot using an image of a 7.6 disk I backed up off an old LC575 and a 1 MB ROM. The mouse appears to function normally in window mode at in 16 bit color. at 8 bit and below, the screen grays out and leaves a frozen mouse where it last was. Sometimes, it crashes, and sometimes I can move the real mouse to where the thousands of colors option is, blindly click, and it'll return to normal. I wanted to run some older games, including games that have to be set B&W and to 16 color modes to run.

    I have yet to find a way to make this work in full screen either. If I use full screen, the mouse is frozen in the top left corner at any color depth of 8 bits or less, and it moves, but is stuck to the bottom edge of the screen if I use a larger resolution and higher colors. I can click the emulated mouse, but only if the real mouse is within the bounds of the Basilisk window hidden behind the full screen view. Obviously, if the mouse can't be pointed, clicking is useless. Full screen is not an option for me due to that issue. At least window mode works, but only in Thousands of colors.

    Is there any way to get 8, 4, 2, and 1 bit color working on a Mac running OS X 10.4? I run 3 monitors also, and I'm wondering if that has an effect. Also, I've had to force quit the program a few times because things glitched out and i couldn't get control back. I could click the desktop, drag selection squares, but the menu was hidden by the full screen mode (always on my primary screen-annoying!), and key commands and clicks would return the default system beep.

    So far, emulation has been spot on, though I haven't taxed the emulator either. The only crashes I've seen were from games running auto bit depth changes without asking.

    I bought a 20th Anniversary Mac on ebay, waning an older Mac that could run my old games, but I have to say, it's LCD won't go below 256. I'm still out of luck. I really wanna reminisce about the old days while playing my ancient copy of Color VETTE, and reliving the days of making and playing in custom maps for Marathon of the old abandoned buildings around town that I used to sneak into back in my younger days! I might just have to dig up the old LC575 anyway.

    I hope there is a solution to my color problems.



    • Samuel

      Samuel - 2008-07-07

      I also have this problem, in attempting to run games such as Glider 4 and Glider Pro (with Room Editor). Glider 4 is limited to B&W or 16 colors; Glider Pro needs 16 or 256 colors. I am working on an (Intel) Apple MacBook with Mac OS X 10.5.4 Leopard. Perhaps part of the problem, Leopard system "Display" preferences do not support anything less than Millions of colors (Thousands on some computers). But should not the emulator be able to create a lower-color environment?
      I will be glad to see an update to Basilisk II, free Mac OS versions from Apple, or Glider Pro, whichever comes first.

    • Anonymous

      Anonymous - 2008-08-02

      It won't work for me either when I try to change bit depth to less than thousands in an emulated Performa 631 ('040 series) running 7.5.5 (which most old games require). I am running 10.4.10 on a PPC Mac Mini.  It appears to be a bug in the emulator.  I tried changing OS X bit depth and tweaking emulator bit depth settings and it did not correct the problem.  Anyone have any ideas on how to correct it?  For B&W games try MiniVmac emulator (Mac Plus).
      I have no clue on how remedy the problem on Basilisk II. 

      As for Glider, an OS X version is available from the author at:
      Not sure if it works in 10.5 under Rosetta as I don't have it installed.

      Thank you.


Log in to post a comment.