Content-Type: multipart/alternative; boundary="_000_1356BB0C992302449759B7500882E9026EF917F301SVREXCHANGEin_" --_000_1356BB0C992302449759B7500882E9026EF917F301SVREXCHANGEin_ Content-Type: text/plain; charset="Windows-1252" Content-Transfer-Encoding: quoted-printable I have a problem generating barcode with fop 0.94 and barcode4j 2.1 on IBM = Websphere 7 on iSeries. The only inherent message that gets printed out in the console is: org.apache.fop.render.AbstractRenderer renderXML Some XML content will be i= gnored. No handler defined for XML: http://barcode4j.krysalis.org/ns The fact is that during development we=92ve run a number of tests with our = application deployed on our local machine with Websphere 7 for Windows inst= alled and all was and is running fine. The PDFs were generated with the correct barcodes. Then we=92ve deployed our application to an iSeries and the barcode generat= ion doesn=92t work. The PDFS are no generated without the barcodes leaving the message above. Another =91funny=92 thing is that the barcode4j-fop-ext-complete.jar is cor= rectly loaded after fop.jar and the other libraries on the iSeries as well = as on our local machines. The loading strategy is the same (PARENT_FIRST). Bottom line I=92m assuming this is a class loader problem. I=92m running ou= t of ideas as we=92ve tried different solutions but I cannot discover where= the problem is. On our server we=92ve already set java.awt.headless to true, we don=92t hav= e the same setting on our local machines (I=92ve tried setting it but all i= s still working good). Can anybody have any suggestions to solve this? Any particular parameter/setting to increment logging for barcode4j to see = some more debug messages? I=92m attaching two files that stated the class loaded at runtime for our p= roject, one from on iSeries the other from my local machine where everythin= g is running fine. ANY kind of help will be greatly appreciated. Thanks Gianluca --_000_1356BB0C992302449759B7500882E9026EF917F301SVREXCHANGEin_ Content-Type: text/html; charset="Windows-1252" Content-Transfer-Encoding: quoted-printable
I have a problem generating barcode with fop 0.94 and barcode4j 2.1 on= IBM Websphere 7 on iSeries.
The only inherent message that gets printed out in the console is:
org.apache.fop.render.AbstractRenderer renderXML Some XML content will= be ignored. No handler defined for XML: http://barcode4j.krysalis.org/= ns
 
The fact is that during development we=92ve run a number of tests with= our application deployed on our local machine with Websphere 7 for Windows= installed and all was and is running fine.
The PDFs were generated with the correct barcodes.
Then we=92ve deployed our application to an iSeries and the barcode ge= neration doesn=92t work.
The PDFS are no generated without the barcodes leaving the message abo= ve.
Another =91funny=92 thing is that the barcode4j-fop-ext-complete.jar i= s correctly loaded after fop.jar and the other libraries on the iSeries as = well as on our local machines. The loading strategy is the same (PARENT_FIR= ST).
Bottom line I=92m assuming this is a class loader problem. I=92m runni= ng out of ideas as we=92ve tried different solutions but I cannot discover = where the problem is.
On our server we=92ve already set java.awt.headless to true, we don=92= t have the same setting on our local machines (I=92ve tried setting it but = all is still working good).
 
Can anybody have any suggestions to solve this?
Any particular parameter/setting to increment logging for barcode4j to= see some more debug messages?
 
I=92m attaching two files that stated the class loaded at runtime for = our project, one from on iSeries the other from my local machine where ever= ything is running fine.
 
ANY kind of help will be greatly appreciated.
 
Thanks
 
Gianluca
--_000_1356BB0C992302449759B7500882E9026EF917F301SVREXCHANGEin_--