Hello everyone,
 
Now that I finally got backups working as they should, I have ran into a problem.  Right now we have a machine that has a great deal of problems (drivers missing, programs are installed that we do not know how they got there, etc.) and I was hoping to be able to restore using the rsync protocol.  So, I took the machine and booted it to a RescueCD.  I set the rsyncd.conf to match what was originally setup on the Windows workstation (except /cygdrive now points to the mountpoint).  I also included the secrets file and mounted the drive using ntfs-3g.  So, when I go to restore, it seems that everything is going well.  For example, when I look at lsof, things are moving along.  However, after a while, certain "threads" start hanging in lsof and I start seeing a trend.  For example, the user had a file with a in it which caused the error message of "invalid or incomplete multibyte or wide character 84."  This lead me to believe that the problem was with the charset so I started off my journey looking for a solution.  Hours later, I tried adding --iconv to the argument list for recovery and specific the charsets of UNICODE, UTF-16, and UTF-8 to no avail (I also added the charset argument in the .conf file).  At that point, it would backup to the point where the "funny charactered" file was and decide to throw a bunch (about 10 lines) of Japanese or Chinese (literally) and then terminate saying that the "backup was successful."  I finally piddled around with that problem until I finally wrote an exception on the local client's .conf file to exclude files that matched the name of the file in question.  So, I ran it again and then got another problem with .edb files being backed up.  They weren't copying back to the system.  Instead, in lsof, I would see filename.edb.adfXE (or something of that nature).  It would sit there and never really backup (it was hung).  I also tried deleting the original file in hopes that would solve the problem.  Instead, the original file gets recreated along with a new filename.ext.djldaYY (it's not just .edb).  I then added *.edb* into the exception list but every time I run the restore process, it comes up with yet another file that won't copy...which is getting old real fast since I have to restart the whole restore process after adding it to the exception list.  So, I'm a bit lost on what to do now to get the machine back in the state it was in during the backup.  I'm pretty certain I'm going to have to format this machine anyway but I'd really like to get a taste of how to do a restore properly.
 
Does anyone have any ideas or suggestions?