Thanks for the detailed information.  Sorry about the delay in replying.

Yes, the script doesn't update individual client files.  However, RsyncClientCmd is no longer used in 4.0.0, so it shouldn't matter if there is still an orphan setting in a host-specific

To clarify your second email, do rsync backups now work correctly?  The rsync_bpc commands in your original email look correct - it appeared for some reason that the ssh to the backup client was failing for some reason.  Perhaps there was some other orphan setting that was causing a problem.

Good point on rsync in MacOSX.  2.6.9 is almost 7 years old.

I'd like to learn more about the empty download for zip and tar.  Were you selecting files from a old (pre-4.x) backup, or a new (4.x) backup?  How many files did you select?  A couple of individual files, or an entire directory?


On Sat, Sep 28, 2013 at 9:29 AM, Steve Palm <> wrote:

On Sep 28, 2013, at 8:43 AM, Steve Palm <> wrote:
> Please bear with my rambling before, I am continuing to try to nail down the issues that are happening, but thought I would throw out what I have so far to get suggestions if anyone had some to share. :)

 More notes:

I tried to do a restore test operation, both the tar and zip download options gave me zero-byte files on the client with this in the logs:

2013-09-28 09:05:55 User stevep downloaded tar archive for backuppc, backup 1487; files were: /
2013-09-28 09:08:30 User stevep downloaded zip archive for backuppc, backup 1489; files were: /

A direct restore seems to have worked fine.

I upgraded rsync on Mac OS X system to v3.0+ and that seems to resolve the issue after putting back the --protect-args rsync parameter.  Yay!  :)  WHY is Apple still sending out rsync version 2.6.9!  Grrr....  :)

Still found client configurations that had an old format rsync command line in the config file that did not get converted, and seemed to be causing problems: ??

$Conf{RsyncClientCmd} = '$sshPath -q -x -l root -c arcfour $host nice -n 10 $rsyncPath $argList+';
$Conf{RsyncClientRestoreCmd} = '$sshPath -q -x -l root -c arcfour $host nice -n 10 $rsyncPath $argList+';

I touched those up and backups seem to be running, will watch for completion.

So, basically, what I think I found so far:

  * For Mac OS X it now seems to require rsync v3.0+
  * I grepped the config files looking for RsyncClientCmd and removed them all
  * Make sure all rsync hosts have a good config if not using master config/defaults

Still not sure on the Windows host and the apparent "freeze", but I will have to wait for the server to settle down a little bit from the other jobs it is running right now to test that again.


October Webinars: Code for Performance
Free Intel webinars can help you accelerate application performance.
Explore tips for MPI, OpenMP, advanced profiling, and more. Get the most from
the latest Intel processors and coprocessors. See abstracts and register >
BackupPC-devel mailing list