----- Original Message -----
From: Alex Machina
To: BackupPC-users@lists.sourceforge.net
Sent: 10/30/2011 12:48:46 AM
Subject: [BackupPC-users] Cannot Backup SMB Share

The standard configuration does not backup an SMB share. The error message is:

Contents of file /var/lib/BackupPC//pc/pavilion/XferLOG.bad.z, modified
2011-10-29 19:30:09

Running: /usr/bin/smbclient \\\\pavilion\\Users -U amachina -E -N -d 1
-c tarmode\ full -TcrX - full backup started for share Users
Xfer PIDs are now 25227,25226
tar_re_search set
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows 7 Professional 7601 Service Pack 1]
Server=[Windows 7 Professional 6.1]
tree connect failed: NT_STATUS_ACCESS_DENIED
Anonymous login successful
Domain=[WORKGROUP] OS=[Windows 7 Professional 7601 Service Pack 1]
Server=[Windows 7 Professional 6.1]
tree connect failed: NT_STATUS_ACCESS_DENIED
tarExtract: Done: 0 errors, 0 filesExist, 0 sizeExist, 0 sizeExistComp, 0
filesTotal, 0 sizeTotal
Got fatal error during xfer (No files dumped for share Users)
Backup aborted (No files dumped for share Users)
Not saving this as a partial backup since it has fewer files than the prior one
(got 0 and 0 files versus 0)

The configuration settings are:

$Conf{XferMethod} = 'smb';
$Conf{SmbShareName} = 'Users';
$Conf{SmbShareUserName} = 'someuser';
$Conf{SmbSharePasswd} = 'somepasswd';
$Conf{SmbClientPath} = '/usr/bin/smbclient';
$Conf{SmbClientFullCmd} = '$smbClientPath \\\\$host\\$shareName
$I_option -U $userName -E -N -d 1 -c tarmode\\ full -Tc$X_option -
$fileList';

Executing the SmbClientFullCmd manually from a terminal window results
in a successful run (after substituting for the parameters
appropriately).

Changing the SmbClientFullCmd to

$smbClientPath //$host/$shareName -A /some/path/.auth -E -N -c
"tarmode full" -Tc -

also fails when run by BackuPC (but not when run from the command
line), but no useful information is provided in the log except:

Started full backup on pavilion (pid=24547, share=Users)
Backup failed on pavilion (No files dumped for share Users)

The host being backed up is Windows 7:

[root@spectra ~]# smbclient -L pavilion -A /home/amachina/.smb.auth
Domain=[PAVILION] OS=[Windows 7 Professional 7601 Service Pack 1]
Server=[Windows 7 Professional 6.1]

Sharename Type Comment
--------- ---- -------
ADMIN$ Disk Remote Admin
C$ Disk Default share
D$ Disk Default share
E$ Disk Default share
IPC$ IPC Remote IPC
print$ Disk Printer Drivers
Users Disk
Domain=[PAVILION] OS=[Windows 7 Professional 7601 Service Pack 1]
Server=[Windows 7 Professional 6.1]

Note that original error message states that "anonymous login" was
successful, but the intent is to login to the SMB share using the
configured username and password. All attempts to mangle the
parameters to force a login of a specific username/password
combination fail from BackupPC (but work when executed from the
command line).

Anybody have any suggestiions?

------------------------------------------------------------------------------
Get your Android app more play: Bring it to the BlackBerry PlayBook
in minutes. BlackBerry App World™ now supports Android™ Apps
for the BlackBerry® PlayBook™. Discover just how easy and simple
it is! http://p.sf.net/sfu/android-dev2dev
_______________________________________________
BackupPC-users mailing list
BackupPC-users@lists.sourceforge.net
List: https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki: http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/

Check your samba version.  There are reported problems with Win7 and samba for older versions.  A google of samba and windows 7 should help you find a site.

Larry