Hello again list!

I'm running into some trouble with excluding directories in rsyncd.conf on a windows machine. The machine in question is dying quickly, and rarely stays "alive" for more than 30 minutes or so. Because of that, I'm trying to slowly increment what is being backed up to the debian server.

The main problem is the excludes list is supposed to be separated by spaces, and of course everyone's favorite OS has spaces in directory names. I tried to get around this with quotation marks, but the things I ask to be excluded are still included. I also tried adding explicit excludes to the config on the backuppc, and that similarly didn't take. Here are the key configs -

From the host.pl on the backuppc -

$Conf{RsyncShareName} = [
  'documents'
];
$Conf{BackupFilesExclude} = {
  '/Administrator/' => [
    ''
  ],
  '/Application Data/' => [
    ''
  ],
  '/All Users/' => [
    ''
  ],
  '/Default User/' => [
    ''
  ]
};

This is the rsyncd.conf that is running from the cygwin-rsyncd 2.6.8_0 package from the backuppc page at sourceforge. I am trying to start with the smallest possible amount of data from this machine, then I'll include things one directory at a time. 

use chroot = false
max connections = 4
log file = c:/rsyncd/rsyncd.log
pid file = c:/rsyncd/rsyncd.pid
lock file = c:/rsyncd/rsyncd.lock
[documents]
    path = c:/Documents and Settings
    comment = Everything
    strict modes = false
    auth users = backuppc
    secrets file = c:/rsyncd/rsyncd.secrets
    hosts allow = 192.168.68.103
    read only = false
    list = true
    exclude = "/Administrator/" "/All Users/" "/Application Data/" "/Default User/" "/Jennie and Andy/.java/" "/Jennie and Andy/.javaws/" "/Jennie and Andy/.jpi_cache/" "/Jennie and Andy/Application Data/" "/Jennie and Andy/Cookies/" "/Jennie and Andy/Desktop/" "/Jennie and Andy/Favorites/" "/Jennie and Andy/Local Settings/" "/Jennie and Andy/My Documents/" "/Jennie and Andy/NetHood/" "/Jennie and Andy/PrintHood/" "/Jennie and Andy/Recent/" "/Jennie and Andy/SendTo/" "/Jennie and Andy/Start Menu/" "/Jennie and Andy/Temp/"


All in all that should leave only about 10 Mb worth of data under c:\Documents and Settings that should be copied to the server, but every attempt at rsyncing grabs absolutely everything in documents and settings.

Thanks for the help.

Peace,
Jim