Hello BackupPC Community,

Im totally new to BackupPC. Yesterday I installed a completely new backup server using the latest ubuntu-server distibution (9). Then I installed Ubuntus BackupPC package and configured a host, which I would like to backup.

The basic configuration seems to work (I can use the web interface). Unfortunately, the backup seems to "hang". 

When I issue this command on my backupserver as backuppc user:

--------------------------------------------------------------------------------------------------
/usr/bin/ssh -l backuppc servertobackup.example.com sudo ls -la
--------------------------------------------------------------------------------------------------

I get a directory listing, which should mean, that the ssh authentication should work.....

By issuing on the command line (for testing):
--------------------------------------------------------------------------------------------------
/usr/bin/ssh -v -l backuppc servertobackup.example.com sudo /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --recursive --ignore-times . /
--------------------------------------------------------------------------------------------------

the command is sent to the server and nothing happens. I guess this is normal because the command will need its time on the other side.....


But unfortunately, when triggering the same command via the backuppc webinterface - after 2 hours - the backup fails with these logs:

########### BASIC LOG ##############################

Contents of file /var/lib/backuppc/pc/servertobackup.example.com/LOG.072009, modified 2009-07-29 14:26:50

2009-07-29 09:47:21 full backup started for directory /
2009-07-29 11:54:16 Got fatal error during xfer (fileListReceive failed)
2009-07-29 11:54:21 Backup aborted (fileListReceive failed)
#################################################



############# XFER LOG #####################################################

Contents of file /var/lib/backuppc/pc/servertobackup.example.com/XferLOG.bad.z, modified 2009-07-29 11:54:21

full backup started for directory /
Running: /usr/bin/ssh -v -x -l backuppc servertobackup.example.com sudo /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --recursive --ignore-times . /
Xfer PIDs are now 2309
Got remote protocol 1852141647
Fatal error (bad version): OpenSSH_5.1p1 Debian-5ubuntu1, OpenSSL 0.9.8g 19 Oct 2007

Remote[105]: 1 Debian-5ubuntu1, OpenSSL 0.9.8g 19 Oct 2007
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to servertobackup.example.com [-CUT-] port 22.
debug1: Connection established.
debug1: identity file /var/lib/backuppc/.ssh/identity type -1
debug1: identity file /var/lib/backuppc/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file /var/lib/backuppc/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_4.3p2 Debian-9etch3
debug1: match: OpenSSH_4.3p2 Debian-9etch3 pat OpenSSH_4*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.1p1 Debian-5ubuntu1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-cbc hmac-md5 none
debug1: kex: client->server aes128-cbc hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'servertobackup.example.com' is known and matches the RSA host key.
debug1: Found key in /var/lib/backuppc/.ssh/known_hosts:2
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,password
debug1: Next authentication method: publickey
debug1: Trying private key: /var/lib/backuppc/.ssh/identity
debug1: Offering public key: /var/lib/backuppc/.ssh/id_rsa
debug1: Server accepts key: pkalg ssh-rsa blen 277
debug1: read PEM private key done: type RSA
debug1: Authentication succeeded (publickey).
debug1: channel 0: new [client-session]
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending command: sudo /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --recursive --ignore-times . /
 ��oJ�    . �� J�A  aquota.user4j� I��  sbin  � I�A 	uninstall J�G  root �� J  boot e� G  info ��G� scripts   devT �	 J  sysZ	 J  _vhosts �� G�� /var/www/vhosts  usr  ��F�A  var ���F  docs ��G 	migration  �1H  home ��nJ  tmp`��oJ�C  screenshots J�G�A  etc  'oJ  initrd f��F  opt �  G  apps k�G  bin :� I  selinux 	C�E 
lost+found@Z��F�A  media f��F�A  forms ��G  procZ	 JmA  lib0-� I�A .spamassassin �� J�A  srv f��F�A  mnt �cCE sbin/ldconfig�` ��KH��>   ifdown�g�  E  '� :  sysctl #�d E:  iptables��"eE:  bootlogd(,��3H: 	dhclient3tV p��E:  MAKEDEV`��@�D:  dhclient-scripts j��E:  blockdev"W mG:  logsave\ @TXG:  init� ��3H:  swapon|-g mG:  modprobe�bJ��E:  fsck.nfsM ��3H>  	mkfs.ext3��@TXG͋ : 
plipconfig� �u�C>   e2fsck�? @TXGˋ :  fixfiles   C�E>   sck.ext2�? @TXGˋ :  portmap�0�E�E:  update-modulesoH��E:  dumpe2fs�(@TXG:  losetup4ag mG:  killall5x'��3H:  getty�9W mG:  pmap_set��E�E:  setfiles�6(C�E:  mkswap�+W mG>   e2fs��@TXG͋ : 
pivot_root W mG�  fsck.cramfs�(8  ksyms ���F�� insmod.modutils8  slattach�l�u�C��:  cfdisk �X mG: installkernel� ,]�D:  sfdisk��X mG8  lsmod.modutils ���F�� insmod.modutils8  hwclock iW mG��8  modprobe.modutils ���F�� insmod.modutils8  rarp�\�u�C��:  syslogd4o&{uD: 	resize2fso@TXG:  awl W mG:  mmodH#J��E8  unix_chkpwdPF � Gm�8 	pmap_dump� �E�E��>   e2label�V@TXGϋ : 
fsck.minix�MW mG:  halt�+��3H�  runlevel@ :  start-stop-daemonHHE:  fdisk�! X mG>  	mkfs.ext2��@TXG͋ 8  telinit �� I�� init8 	badblockstF@TXG��8  reboot �� I�� halt8  ip6tables-save@��"eE��8  lsmod
���F��

[ ... cut long message ...]
icon/flags0�70D�A�R cpu �R browser �R other �R mime �R clock �R os �R flags/nato.png����X km.png  �Y h.png��X nc.png��X jp.png��X tz.png��X kr.png  �X pg.png��X kp.png  �X im.png# �X aero.png} �X mq.png��X gs.png��X ac.png� �X ec.png��X bo.png��X la.png��X gf.png  �X be.png��X ws.png[ �X nl.png��X wf.png  �X no.png��X ze.png��X tw.png��X bh.png��X kz.png# �X ro.png��X ma.png��X ad.png��X li.png��X sv.png��X name.png} �X at.png��X si.png��X lc.png  �Y t.png��X cz.png��X rw.png��X ao.png��X sz.png? �X
Read EOF: 
Tried again: got 0 bytes
fileListReceive() failed
Done: 0 files, 0 bytes
Got fatal error during xfer (fileListReceive failed)
Backup aborted (fileListReceive failed)
Not saving this as a partial backup since it has fewer files than the prior one (got 0 and 0 files versus 8125)
######################################################


What can I do? How can I debug this?

Thanx in advance!