Hi Everyone,
  Some more info on this problem which could hopefully bring some help my way.  I dinked around in the backuppc_dump script and had it dump out the config values it was getting for the client I'm testing.  Oddly enough it appears as if it's not reading my config file at all...it never sets ClientNameAlias, nor any of the other non standard options I set.  I changed my top dir, but backuppc sees my new top dir, and doesn't complain about the new path.
  Running out of ideas I allowed ClientNameAlias to be set via the CGI interface, set it for my host, and magically the dump sees my client now (However it fails the dump looking to backup the wrong partition).  I look at the config file in my new top dir for this client and the changes I made via the CGI interface are not represented.  I run a locate for this hosts config file on my whole system and don't find anything other than the one in my new top directory.  It's as if backuppc is using some config that's specific to the CGI interface.  Is this possible?  Where the hell would the config file live if that's the case?  Any help would be greatly appreciated as I loathe the thought of having to run through a bunch of perl code to find the source of the problem :(

On 12/10/2012 4:35 PM, Bruce Thayre wrote:
Hi Matthias,
  Ah I see, I guess I shouldn't mix bash notation when asking about a command I run in a shell.  So what you recommend is exactly what I've been doing.  Assume my router is MyRouter.domain, and the client behind the router is MyClient.  In MyClient's respective config file I have:
$Conf{ClientNameAlias} = 'MyRouter.domain';

  When I run the command:

sudo -u backuppc /usr/share/BackupPC/bin/BackupPC_dump -f -v MyClient
  I get the output:
Name server doesn't know about MyClient; trying NetBios
cmdSystemOrEval: about to system /usr/bin/nmblookup MyClient
cmdSystemOrEval: finished: got output querying MyClient on
name_query failed to find name MyClient

NetBiosHostIPFind: couldn't find IP address for host MyClient
host not found

  So what's going on is despite having the ClientNameAlias set, backuppc assumes the hostname is a netbios name.  Strangely enough the ip address that it dumps out is on my subnet, but is not actually in use.  I've set the backup method as rsyncd, so I would think backuppc would not use any netbios/samba related stuff.  I've also tried using my router's ip address just in case I was having DNS problems, but I see the exact same behavior.  Sorry for the confusion, and thanks for the patience.


On 12/10/2012 3:32 PM, Matthias Meyer wrote:
Bruce Thayre wrote:

Hi Matthias,
   Thanks for your prompt reply!  I gave your recommendations a try and
had no luck.  Setting CLIENT='name as in $Conf{ClientNameAlias}' doesn't
actually substitute the value for ClientNameAlias.  Bash doesn't know
the config file, so just returns that as a string if I try to ping

    bash-4.1$ echo $CLIENT
    name as in $Conf{ClientNameAlias}
if your client called "MyClient" than:
ping -c2 $CLIENT
sudo -u backuppc /usr/share/BackupPC/bin/BackupPC_dump -f -v $CLIENT

I also tried adding those nmblookup specific lines to my config, but get
the same output as before when running the dump command. What confuses
me is I specify rsyncd as my method, so I'm not sure why backuppc is
trying to use netbios names for lookups.  I also don't know where it's
getting this funny ip that isn't actually there, but if it were
registered would be on our subnet.  For some reason or another, backuppc
won't try to ping what I specify as ClientNameAlias, and instead tries
to lookup the host netbios name.  Any ideas?  Thanks so much for the help!

On 12/8/2012 1:33 AM, Matthias Meyer wrote:
Bruce Thayre wrote:

Hello Everyone,
    I've been a maintainer of an old install of backuppc until our
recently died.  I've reinstalled and brought all other services back
except for backuppc.  Many of our backup clients are behind routers and
I had been using the ClientNameAlias option in their respective
config.pl files.  However, when I try the test command:
bash-4.1$ /usr/share/BackupPC/bin/BackupPC_dump -f -v $CLIENT
CLIENT='name as in $Conf{ClientNameAlias}'
ping -c2 $CLIENT
sudo -u backuppc /usr/share/BackupPC/bin/BackupPC_dump -f -v $CLIENT
I get the output:

Name server doesn't know about $CLIENT; trying NetBios
cmdSystemOrEval: about to system /usr/bin/nmblookup $CLIENT
cmdSystemOrEval: finished: got output querying $CLIENT on
name_query failed to find name $CLIENT

NetBiosHostIPFind: couldn't find IP address for host $CLIENT
host not found

    I'm a little confused by the output.  I have the host setup with
DHCP=0, and rsyncd is my backup method in /etc/config.pl.  I'm not quite
sure why backuppc is trying to use the hostname as a netbios name, and
why it seems to ignore the router ip I provide in the client's config.pl
file.  More perplexing is that nmblookup seems to return an ip address,
but that ip address is not in use.  It won't resolve using nslookup, so
I'm can't understand where it was found. Any insight would be greatly

My Config:
$Conf{NmbLookupPath} = '/usr/bin/nmblookup';
$Conf{PingPath} = '/bin/ping';

$Conf{ClientNameAlias} = 'name of CLIENT';
$Conf{NmbLookupCmd } = '$nmbLookupPath -A $host';
$Conf{NmbLookupFindHostCmd } = '$nmbLookupPath $host';
$Conf{FixedIPNetBiosNameCheck} = '';


LogMeIn Rescue: Anywhere, Anytime Remote support for IT. Free Trial
Remotely access PCs and mobile devices and provide instant support
Improve your efficiency, and focus on delivering more value-add services
Discover what IT Professionals Know. Rescue delivers

BackupPC-users mailing list
List:    https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki:    http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/