On 26/11/12 13:25, Matthew Grob wrote:

Thanks for your reply.  I understand what you're getting at and I tried several ways to do that.  I was able to set things up so the paths are exactly the same on the two machines (the local and the remote client).

But for some reason I cannot get the local backup to actually run.  I tried both rsync and tar transfer methods - both fail.   I thought maybe it was related to permissions but I tested command line versions of rsync while logged in as the backupPC user and those all worked.

Below is the log output.   Not sure why it's not working - again it's the local backup that is not working (the remote one works great).


Contents of file /var/lib/backuppc/pc/localhost/XferLOG.bad.z, modified 2012-11-25 20:20:59

full backup started for directory /
Running: /usr/bin/ssh -q -x -l root localhost /usr/bin/rsync --server --sender --numeric-ids --perms --owner --group -D --links --hard-links --times --block-size=2048 --recursive --ignore-times . /
Xfer PIDs are now 25010
Rsync command pid is 25010
Read EOF: Connection reset by peer
Tried again: got 0 bytes
Done: 0 files, 0 bytes
Got fatal error during xfer (Unable to read 4 bytes)
Backup aborted (Unable to read 4 bytes)
Not saving this as a partial backup since it has fewer files than the prior one (got 0 and 0 files versus 0)

On the first backup, you needed the backuppc user to accept the ssh key for the remote host, you probably need to redo this for the localhost ssh key. As the backuppc user, ssh root@localhost and accept the key, then re-run the backup.


Adam Goryachev
Website Managers