Le 30/07/2011 00:36, owens@netptc.net a écrit :


_______________________________________________

Alain

1.  The samba wiki advises the use of a later version of samba to support Win7.  What samba version are you on?

2.  The same wiki advises a couple of registry patches to the Win7 machine.  Did you find them necessary?

Larry


Hi Larry,

I am using samba 3.5.6, which is shipped with Scientific Linux 6 (a clone of RHEL 6). I found it was required to use this version, not for win 7, but because I recently migrated  from windows 2003 R2 to 2008 R2, as domain servers for an Active Directory domain. Windows 2008 R2 uses stronger cryptology to communicate with clients, and the main change I had to do is to adapt the encryption types used in /etc/krb5.conf :

[libdefaults]
  default_realm = DOMAIN.COM
  default_tgs_enctypes = arcfour-hmac-md5 des-cbc-crc des-cbc-md5 des3-hmac-sha1
  default_tkt_enctypes = arcfour-hmac-md5 des-cbc-crc des-cbc-md5 des3-hmac-sha1
  clockskew = 300
 
See :
http://itscblog.tamu.edu/joining-samba-to-a-windows-2008-r2-domain/

I also migrated from samba ( 3.0.33) to samba3x (3.5.6) on CentOS 5.6 machines, with the same changes in enctypes.

I did not apply any particular registry patches ton win 7 machines.

Alain