cbarratt@users.sourceforge.net wrote:
I've just setup a new backup server (the old one is getting 
decommissioned).  This new one is on Redhat 9.0 with BackupPC 2.0.0.

I have installed it Mod Perl as per the documentation.  However I get 
the following error when initating a Full Backup on a client:

Insecure dependency in exec while running with -T switch at 
/backups/bin/BackupPC line 557

Unfortunately, Perl is not really my strong point - any help would be 
greatly appreciated!
    

What version of perl are you running?

I'd recommend just removing the -T switch on line #1 of
/backups/bin/BackupPC.

Craig

  
Hi Craig,

The perl version is : 5.8.0, basically the standard one that comes with Redhat 9.

I removed the -T and the problem has gone away - is this going to cause any security issues for us at all?

BTW - BackupPC is a great tool - thanks for all the hard work!

Richard.