I've been using backuppc for over 5 years now.  Saved my butt more than once.  Had a recent drive failure on my file server and set up a new one.  Did the restore into this new box and was back in business the same day.
 
Since that backup server was of the same (very old) vintage as the one that failed, I got a new box (actually, a low-power eeebox, which is what I have been running backuppc on for the last year or so as well - works well and saves electricity).
 
I was ready to put the new eeebox on as my file server and did the restore (note, not a "restore" to the new interim file server, but to the new eeebox, which I am calling "temp" for now), but it said it had errors in the restore.  I looked at the errors and it listed every file.  However, it appears every file was transferred.  It listed the "errors" such as this:
 
Sending /MyFiles/pictures/IMG_5007.JPG (remote=MyFiles/pictures/IMG_5007.JPG) type = 0
[ skipped 1 lines ]
 
So I did the restore to "temp" again.  This time, it went through all the files, but the process never exited.  I had to hit stop/dequeue and it said restore failed.  Then I looked at the log file, and it apparently had restored the files again (note, I visually watched both the hard drive lights and the network hub lights to see that transfers were happening, and only dequeued after lights stopped blinking).  
 
So I tried smaller.  I restored some small files/directories, and things worked as expected.
 
But when I tried restoring larger files/directories, I got the same thing - restore complete but process not exiting (it still shows in progress on the status page).  The end of the log file for this shows this, where I just tried to restore the large "stuff" directory.
 
Sending /stuff/yankees/yankee-2.jpg (remote=stuff/yankees/yankee-2.jpg) type = 0
[ skipped 1 lines ]
exiting after signal INT
restore failed: aborted by user (signal=INT)
 
Yeah, I went to a Yankees game once even though I'm a Red Sox fan (free tickets).  More importantly, the yankee-2.jpg file is the last (alphabetically) file in the last (alphabetically) yankee directory.  All the files were restored.  But the process never ended until I hit stop/dequeue and the restore gets marked as "failed".
 
I tried rebooting "temp", and I even added timeout = 0 to the rsyncd.conf file on "temp" (restarting rsync) but nothing changed.
 
All these boxes are running Debian by the way.
 
Any help would  be appreciated.
 
Thanks.
 
JS