Ok it seems it is working correctly, but I'm confused about something.

Currently I have the directores 45 - 57. Each directory contains 1.9gb of space, except for the 45 directory which is the full backup, takes up 4.2gb. So you would think that, 1.9gb multiplied by al the directories (12) would be a total of at least 25gb. But no, doing a du -hs on all the directories, I get a total of 5.5gb. I was sure though that when I tested BackupPC previously, each directory would only contain the incrementals. So whats going on here? are these hard links?

Looking at the logs in the cgi-bin interface, the "New Files" section seems to display the correct incremental size of each dir.

On Sat, 2003-12-20 at 22:19, Ben wrote:
Hey gday... I have this very weird problem. First off, I wanted to emulate exactly what I will be doing before I go out and actually backup some machines. Seeing that I will be backing up machines over the internet, the first step is to actually get the files onto the backup server with backuppc. So, this is what I do:

Go out to some site, ghost their hard disk, come back, put the hard disk into the backup server, then add a host and make use backuppc to copy the files from the mounted drive to the correct directory (using rsync or whatever, connecting to itself). That part worked.

Next, modify the hosts file so that now that host is pointing to the real IP of the PC I want to backup, for incrementals. This also worked, suprisingly, well to a point. This is where it gets interesting.

Taking a look at the output of ifconfig, I can see that only 20mb or so has been transferred for the incrementals, which is fine. (I'm doing this local first, on my internal LAN within the same subnet). So, looking at that, it all looks fine. But, taking a look at the incremental directory, the amount of space that it has used is just as much as the full backup! But it hasnt actually transferred that much. Interesting, has anyone ever come across that before?