AzSMRC not responsive/loses connectivity

  • coreying

    coreying - 2007-04-02

    I've been using the 0.99RC of AzSMRC for about a week now.
    I've noticed that if you have AzSMRC minimized for any substantial (say an hour?) period if time, when I come back to it, the system tray icon has the orange lightning bolt through it, and when I double click and the main interface reopens, nothing is updating.

    It also won't let me reconnect unless close AzSMRC and reopen it. Attempting to reconnect just results in nothing happening.

    When this happens, I sometimes can't close AzSMRC by right-clicking on the system tray icon, as the menu never appears. Going to Main > Exit works ok though.
    I didn't have this issue with the previous stable version (0.9.8?) that I was using.

    I'm running Windows XP SP2, not sure what other details you might want to know.

    Has anyone else experienced this ?

    • cTd - Crash Test Dummy

      What is your connection speed?

    • coreying

      coreying - 2007-04-11

      Connection speed at home is ADSL2+ - usually about 6Mb down, 1Mb up.
      Connection speed at work is unknown.... well in excess of 1Gb each way.... however there are thousands of people using it, so it can still get 'slow'

    • Vorchun

      Vorchun - 2007-09-01

      I confirm this bug with 0.9.9 version. And I don't need to make AzSMRC minimized, it looses connection straight after connecting to server and won't reconnect until application is restarted. Tried 0.9.8 and it works absolutely fine.

    • Leonard Brünings

      With this description it is rather hard to find a solution.
      Does this happen if you have no torrents running?
      Are there some other aspects that might have a connection with the problem?
      Did you modify the refresh time?
      Was this a clean install?
      And anything else that might help.

    • Alex Malinovich

      Alex Malinovich - 2007-09-05

      I had a similar issue happen to me a few days ago but I tracked it down to a bad torrent file. Every time I would check the description of this particular download it would cause AzSMRC to lose connection to the server requiring a complete restart of the client. (Disconnecting and reconnecting didn't work.) I ended up deleting that torrent from the queue and haven't had a problem since. Don't know if it's related or not, but just pointing it out in case it helps.

    • Vorchun

      Vorchun - 2007-09-17

      Sorry, was away from PC.

      >With this description it is rather hard to find a solution.
      Yes, I understand. I am QA Engineer myself, and realize such description isn't very useful for developer. I will try to give as much details as possible.

      >Does this happen if you have no torrents running?
      At the time some downloads are in progress, I will try without torrents as soon as possible. Maybe it's because of a specific torrent, like in Alex Malinovich case.

      >Are there some other aspects that might have a connection with the problem?
      Don't think so, 0.9.8 works absolutely fine with the same connection. It's 2mb/512kb ADSL home.

      >Did you modify the refresh time?
      Nope, both values are default.

      >Was this a clean install?

      >And anything else that might help.
      I will turn on debug messages and post anything that will appear in the console.


Log in to post a comment.