ScaneRSS on Linux with XP AzSMRC-client

Plugins
Rutger
2009-02-18
2013-01-31
  • Rutger

    Rutger - 2009-02-18

    I have a Vuze install on Ununtu and can login using the AzSMRC client. Would like to use the ScaneRSS plugin on the client.

    So far:
    Got it to work on Vuze

    Made a directory in the AzSMRC installdir on XP (..\plugins\scannerrs

    put ScaneRSS_AZ_0.9.9.jar in it

    Now the Linux-bit.
    Where do I put what files? I do NOT understand the instruction:

    You need to make sure to move the jdom_1.0.jar found in either /azsmrc or /scanerss dir to ~azureus/shared/lib/

    Can someone please elaborate?

    Also:

     
    • Rutger

      Rutger - 2009-02-18

      Excuse me..
      Also this instruction is not clear to me. Sorry for being a n00b

      "move the jdom_1.0.jar and commons-codec_1.3.jar into ~/azureus/shared/lib/. "

      this is what I found that let me to these actions:

      "Well you need to put ScaneRSS_AzSMRC_0.9.5.1.20061130.jar in ~/AzSMRC/plugins/scanerss on your client machine.
      And move the jdom_1.0.jar and commons-codec_1.3.jar into ~/azureus/shared/lib/. "

      Any further help would be most appreaciated. I love AzSMRC!

       
      • Leonard Brünings

        Hi,

        you need ScaneRSS installed on Azureus/Vuze too if you want the full functionality.

        If you installed AzSMRC 1.0 via the plugin list the libs should already be in ~/azureus/shared/lib/. (azureus = vuze)
        ~ = where ever you installed Azureus

         
        • Rutger

          Rutger - 2009-02-18

          WEll. The only thing i can find is an /opt/Vuze dir. it has a plugins dir as well with a scannerss map.

          this contains scannerss_0.9.9.jar

          old version maybe?

          no mention of shared/lib/

          also. I still don't get the install on the client under windows.

           
          • Leonard Brünings

            Then create /opt/Vuze/shared/lib/ and move the jdom_1.1.jar and commons-codec_1.3.jar from azsmrc in it.

            On the clientside goto AzSMRC dir and create plugins/scanerss and drop ScaneRSS_AzSMRC in it.

             
            • Rutger

              Rutger - 2009-02-18

              Done and done but still no joy. It seems that the client doesn't recognise the plugin.

              Am I correct to assume it should appear unmder the plugins menu-item? this has no content at the moment. als in Preferences under local plugins there are none. Do I need to run something in java perhaps?

               
              • Leonard Brünings

                Could you list the contents of the client directory and subdirs?

                 
                • Rutger

                  Rutger - 2009-02-18

                  yes we can! :-)

                  in program files\AzSMRC:

                  folder:plugins

                  files:
                  .certs
                  AzSMRC.exe
                  AzSMRC.exe.manifest
                  AzSMRC_1.0.0.jar
                  AzSMRCUpdate.xml.gz
                  commons-codec_1.3.jar
                  confog.cfg
                  jdom_1.1.jar
                  launch.properties
                  launcher.jar
                  licence.txt
                  log4j_1.2.13.jar
                  Readme.txt
                  swt.jar
                  uninstall.exe

                  in folder plugins: nothing exept scanerss folder
                  in scanerss folder:ScaneRSS_AZ_0.9.9.jar

                  Again many thanks in advance.

                   
                  • Leonard Brünings

                    And there is the problem ScaneRSS_AZ_0.9.9.jar is not ScaneRSS_AzSMRC_0.9.9.jar

                     
                    • Rutger

                      Rutger - 2009-02-18

                      Damn, your good ;-)
                      Works like a charm!

                      Thanks for your patience!

                       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks