Build azsmrc from source

  • Flow

    Flow - 2011-07-13

    I can not compile azsmrc from source. I've checked out the svn, created a file, changed swt.jar=/usr/share/swt-3.5/ but still the build process complains about  the missing package org.eclipse.swt. Looking at the build.xml file it seems that SWTDIR is never really used:
    grep swt.jar build.xml
    <fileset file="${swt.jar}/swt.jar" />
    <define name="SWTDIR" value="${swt.jar}" />

    grep SWTDIR build.xml
    <define name="SWTDIR" value="${swt.jar}" />

    What am I missing here?


  • Leonard Brünings

    If you look around you'll see that those properties are only used for the distribution. Everything that needs to be on the classpath needs to be in the "libs.dir".

    The buildscript is not really great.

  • Flow

    Flow - 2011-07-13

    Yes atm, I am totally confused by the build script :)
    I tried to place swt.jar in lbms/azsrmc/ibs followed by  "ant jar". But this doesn't seem to change anything. Then I tried "ant -lib lbms/azsmrc/libs compile-All", which seems to find the swt.jar but then another .jar is missing.
    What would be needed to produce a azsmrc.jar, without the vuze plugin, that can be launched via "java azsmrc.jar"?


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks