Help save net neutrality! Learn more.

AzSMRC wont run in Leopard

  • alexis hirst

    alexis hirst - 2008-02-24


    i have managed to get AzSMRC working with azureus and another windows machine in my house can connect to it fine, but whenever i try to run the 'AzSMRC_0.9.9.jar' file, i get the following error in the console:
    24/02/2008 13:46:36 [0x0-0x27027][258] Failed to load Main-Class manifest attribute from AzSMRC_0.9.9.jar

    I have tried 0.9.8 and i have the same problem.

    Does anybody else have this problem?


    • Andrew Gocke

      Andrew Gocke - 2008-02-25

      Right now I have yet to get the server checked on all instances on OS X. The client should work fine. I really will try to get it running, but don't hold your breath - I'm swamped right now and can't really do anything until I come back from Boston tomorrow.

    • alexis hirst

      alexis hirst - 2008-02-28

      hi, i thought i might update the status... this is the following error i get: Exception in thread "main" java.lang.NoClassDefFoundError: lbms/tools/launcher/Launcher

    • Leonard Brünings

      Could you please give a complete list of files in your azsmrc dir.

      • alexis hirst

        alexis hirst - 2008-02-28

        i have the following files in my AzSMRC directory:

        launcher.jar, AzSMRC.exe, AzSMRC_0.9.9.jar, AzSMRCupdate.xml.gz, changelog.txt, changelog.txt, swt.jar, readme.txt,, jdom_1.0.jar, commons-codec_1.3.jar, log4j)1.2.13.jar.

        It contains basically the files that are in the downloadable zip file...

        • Leonard Brünings

          I assume that the ")" is an "_" in log4j)1.2.13.jar

          Well then how do you start azsmrc?

          • alexis hirst

            alexis hirst - 2008-02-28

            at first i downloaded the AzSMRC_0.9.9.jar file, because on the downloads it said platform independant, and it was a jar file so i assumed it being java would be self contained and run fine. This, however didnt work, so i downloaded the exe and run it on a windows machine fine.
            I then downloaded the zip file, and checked out the readme and ran it in terminal, using the commands for linux machine under '5.  Manually starting the remote client'...

    • Andrew Gocke

      Andrew Gocke - 2008-02-28

      alexishirst: here's the path i followed:
      1. Download the Client zip file.
      2. Unzip into AzSMRC...
      3. Open Terminal
      4. cd into the directory
      5. run the command java -classpath launcher.jar -Djava.library.path=.
      (or run java -jar launcher.jar, they both seem to work the same)

      Unfortunately, it doesn't look like the latest SVN changes are in this release (including the bug fix for OS X). You can either dl the latest source from SVN, or convince damokles to build a new release ;) (I'll work on the latter).

      • alexis hirst

        alexis hirst - 2008-02-28

        I still get the error No Launchables found...

        I was looking for the source earler on but couldnt find it... could you give me a download link? :)

      • alexis hirst

        alexis hirst - 2008-02-28

        i looked a little harder and found it... ill let you know how it goes...

        • Andrew Gocke

          Andrew Gocke - 2008-02-29

          Correct - the error No Launchables found is due to an error that I fixed in the OS X version a couple months ago. Don't be surprised if it's still a little unstable if you do get the source working, though. Unfortunately, physics is giving no quarter and I have almost no free time this year - I'll try and work on it though.

          • alexis hirst

            alexis hirst - 2008-02-29

            I get the same error... :S

            Oh well, dw, take your time :P

    • thepurplepixel

      thepurplepixel - 2008-03-02

      Hi everyone.

      When I try to run Launcher.jar (all of my folder contents are verified and present), it pops up an error and tells me to look at the console to see what it was. The console says:

      ...Launcher[48280] Checking /Users/(me)/AzSMRC/

      ...Launcher[48280] Application dir '/Users/(me)/AzSMRC/' empty

      So, it looks to me as if it's trying to look for an AzSMRC application... (as all applications start at the /Contents folder). I'm wondering:

      a) Why it's looking for an .app and not a .jar, and,

      b) Why it won't work when all the prerequisites are present

      (oh, and, when I run the normal jar, I also get the 'Failed to load Main-Class attribute from...)


      • Andrew Gocke

        Andrew Gocke - 2008-03-02

        Correct - I'd just like to reiterate that the patch for OS X is in SOURCE ONLY. You'll need to get the latest revision from subversion and find and run Until a jar is built, the only way for it to run on OS X is to get the latest subversion revision and compile it yourself.

    • Alex Malinovich

      Alex Malinovich - 2008-06-08

      I was finally able to get things up and running on my MacBook without having to compile from source, but it took a little bit of doing. Using launcher.jar obviously doesn't work at the moment. I had a nicely set up install on my Linux box including the latest version of all of the necessary libraries, so it took a bit less work than it would otherwise. Note that this is all using the latest beta of AzSMRC, not sure about the release version (which, afaik, hasn't been updated since last year). So, here's my setup:

      1) On the AzSMRC side, you'll want to make sure you have the latest AzSMRC and launcher jars available.
      2) Download and install the following jars. (I believe most of these are included in the zip file available in the download area.)
         * commons-codec.jar (commons-codec_1.3.jar)
         * jdom.jar          (jdom_1.0.jar)
         * log4j.jar         (log4j_1.2.13.jar)
         * swt.jar           (swt-3.3.2.jar)
      2a) (The SWT that I'm using is the latest stable version from the Eclipse project page:\)
      3) Start AzSMRC with the following command line (this is most of the "magic", as it were):

      java -XstartOnFirstThread -cp AzSMRC_0.9.9.jar:launcher.jar:commons-codec.jar:jdom.jar:log4j.jar:swt.jar lbms.azsmrc.remote.client.swtgui.Starter

      (the -XstartOnFirstThread is needed to work around an SWT bug)

      This gets it up and running and mostly usable on my machine. There are definitely issues with it though. It never actually exits when you tell it to, so you have to run it from a terminal and manually hit Ctrl-C when you want it to die. Choosing Quit from within AzSMRC or doing Command-Q doesn't work. Sometimes it seems to exit only to keep running in the terminal.

      I've also seen some strange behavior when adding new torrents. They'll get added without a problem but then show up as blank inside the window. Restarting AzSMRC fixes this. Hope this helps.

      P.S. I've been meaning to get involved in AzSMRC development for a while, but between my complete lack of free time and the fact that I haven't touched Java in nearly 3 years has made that a largely futile endeavor. But I'll be glad to help anyone who is actively developing in any way I can.

    • hhpss

      hhpss - 2008-07-12

      Hi there!

      The method Alex suggested:
      java -XstartOnFirstThread -cp AzSMRC_0.9.9.jar:launcher.jar:commons-codec.jar:jdom.jar:log4j.jar:swt.jar lbms.azsmrc.remote.client.swtgui.Starter
      doesn't work for me neither, I get the following error-message:
      Exception in thread "main" java.lang.NoClassDefFoundError: lbms/azsmrc/remote/client/swtgui/Starter

      Now I already checked out svn hoping on a hint on how to compile from source but here I am still with no clue.
      It doesn't seem to be as easy as issuing ./configure && make in the terminal.

      Is there an easy way for someone like me to compile java?
      I've got DevTools installed, but no idea about java or any programing language for that matter...


    • Monster P

      Monster P - 2009-06-11

      I have managed to bundle AzSMRC as a Mac OS App file ( which loads and runs on my system (10.5 on iMac G5 [PowerPC])

      I am willing to share it with anyone who wants to try it on their systems. I spent a long time cobbling bits of different prople's solutions together until I found a fileset and structure and a java command that actually works. Then I copied chunks of the Vuze .app bundle to use the java stub and their icns files, modified the plist and dropped them together.

      I was pretty shocked when it just started on my first double click.

      Please post on here if you want to try it. I suppose the best thing I could do is share it as a torrent...


      • Karl

        Karl - 2009-06-11

        hey Rich,

        I'd like to try your version for Leopard, how can I get it?


      • Ashley Taylor

        Ashley Taylor - 2009-06-18

        Hello I also would like a copy of this



Log in to post a comment.