Translators Needed

  • omschaub

    omschaub - 2006-11-30

    We are finishing up the code to allow for AzSMRC and ScaneRSS to be translated.  We have AzSMRC almost completed and we are looking for someone to help us translate.  If you are bi-lingual and are interested in being part of this, we would truly appreciate it.

    Time commitment will be minimal as we will only translate new items right before a release.  That is to say, it should not take more than a few minutes about every few weeks or so once the initial translation is done. 

    If you are interested, please contact either myself or damokles, or just leave a note here and we will work out the details.

    Thanks in advance!

    • Paczesiowa

      Paczesiowa - 2007-03-20

      I could translate it to polish but I cant run that translation tool:/

      paczesiowa@paczesiowa ~/Desktop $ java -jar EasyTranslationCreator.jar
      Starting up ETC
      Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/swt/widgets/Display

      "-classpath /usr/share/swt-3/lib/swt.jar" doesn't help either (it works great for azsmrc client)

      • omschaub

        omschaub - 2007-03-22

        We found the problem with this.

        It seems for some reason that we have to recompile the ETC with the new SWT libraries.  Normally files are backwards compatible, but for this one it seems not.  Please wait for damokles to upload version 1.2 and then try with this command

        java -classpath /temp/swt-3.3M5eh/swt.jar:/temp/ETC/EasyTranslationCreator.jar -Djava.library.path=.

        Of course, your directories to your swt3.3 and the ETC jar will be different, so change accordingly.. this command needs to be run from the directory (of course, given the -Djava.library.path command) or just set it to where you have ETC.

        I got it running here on my linux machine with this command

        Let us know if it works for you

    • Paczesiowa

      Paczesiowa - 2007-03-22

      ok now it works. but where is that i18n file? I tried to open all files from azsmrc directory and all are empty except main jar but there are just gazillions of chinese symbols.

    • Paczesiowa

      Paczesiowa - 2007-03-22

      ok. what about character encoding? utf-8, cp852 or windows cp1250? and should this translation be based on polish translation of azureus so it seems familiar to azureus users?

      • Leonard Brünings

        character encoding is utf-8

        >and should this translation be based on polish translation of azureus so it seems familiar to azureus users?


    • Marco

      Marco - 2007-09-05

      I coult translate to Italian, but i need help on how make this.
      Please contact me if you need my help.


    • Leonard Brünings

      Hi Marcolino,

      sure we need every translator that wants to help us.

      Please be more specific with what you need help.
      Here is our Translation Tool

      Read this post to get the files

    • Sebastian Carneiro

      Hi.  My name is Sebastian , and I could translate what you need to Spanish.  I just need some reference to the resources that need to be translated.



    • Leonard Brünings

      Hi Sebastian,

      if you look at the above posts you can find the links to the files. (

      And a new Version of ETC is out
      just unpack it into the AzSMRC dir then you'll have every library that you need.

      So give it a try, and if you have any questions feel free to ask.

      • Sebastian Carneiro

        Thank you !!!

        I'll start translating these properties files to Spanish.

        I tell you when I finish it.



  • anoteng

    anoteng - 2009-11-27

    Could translate into norwegian if needed..


Log in to post a comment.