#60 call gpgme_check_version() before using gpgme_new()

closed
Core (19)
5
2009-08-26
2009-08-02
Anonymous
No

According to the NEWS file, in GPGME 1.2.0 (2009-06-18)

* gpgme_new will fail if gpgme_check_version was not called, or a selftest failed (for example, if -mms-bitfields was not used on MingW32 targets).

This problem affects several applications that use libgpgme, including ayttm, as reported by Jason E. Hale in the FreeBSD ports system:

http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/135911

I'm including Jason's patch for ayttm (see attachment).

Discussion

  • Nobody/Anonymous

    Call gpgme_check_version() at the beginning of aycryption_init()

     
    Attachments
  • Piotr Stefaniak

    Piotr Stefaniak - 2009-08-25
    • assigned_to: nobody --> pstef
     
  • Piotr Stefaniak

    Piotr Stefaniak - 2009-08-26
    • status: open --> closed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks