operating system label is empty

  • Daniel Grosso

    Daniel Grosso - 2011-12-06

    Hi, I'm using awstats 7 (last stable version) to analyze Apache logs
    When parsing the operating system from the user agent field it always returns
    an empty string.


    The lines... - - "GET /html/images/t05.gif HTTP/1.1" 304 - "https://www.jogo
    "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2;
    .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC
    6.0; .NET4.0C; OfficeLiveConnector.1.3; OfficeLivePatch.0.0; MATM)" 463 - - "GET /html/images/destaque_jackpot_semana_3.swf HTTP/1.1" 200
    2906 "https://www.jogossantacasa.pt/web/SCCartazResult/";; "Mozilla/4.0 (compatible; MSIE 7.0; Windows
    NT 6.0; Trident/4.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0;
    InfoPath.2; .NET CLR 1.1.4322; .NET CLR 3.5.30729; .NET CLR 3.0.30729;
    OfficeLiveConnector.1.3; OfficeLivePatch.0.0)" 720


    LogFormat="%host %other %logname %time1 %methodurl %code %bytesd %refererquot %uaquot"


    # OS ID - Hits BEGIN_OS 1

    ... in the database file.

    Tried with v6.95 -> didn't work.

    Tried with v5.9 -> it worked (same log file, same .conf)

    Can anybody help me?


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks