Rob - 2012-04-23


I have installed Awstats v7 to work with IIS stats produced from a Windows
2003 server. All the basics seem to work in that I can generate my html files
as described in the instructions.

The site I'm monitoring is for an internal intranet and I want to exclude the
records generated by our Google Mini search appliance . I have tried several
ways to do this over the last few days using SkipHosts and also SkipUserAgent

The google appliance leaves a iis record as shown below.

2012-04-23 10:21:45 GET /Default.aspx - DOMAIN\username HTTP/1.0 gsa-crawler+(Enterprise;+M2-J8AAAZAKVDDJT; - 200 12463

I have tried adding a combination of the following


I have also tried changing the User Agent name on the Google Appliance to
googlebot so it match the real google. In all cases I still
listed in my host report.

What is also strange if I add SkipHosts="" and leave
SkipUserAgent="" then run with the -showdropped parameter I see the following

Dropped record (host and 8790 not qualified by SkipHosts): 2012-04-14 00:01:43 GET /web/files/signpost_suite/royal_british_legion.JPG - - HTTP/1.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.1;+WOW64;+Trident/5.0;+SLCC2;+.NET+CLR+2.0.50727;+.NET+CLR+3.5.30729;+.NET+CLR+3.0.30729;+Media+Center+PC+6.0;+.NET4.0C;+.NET4.0E;+BRI/2;+InfoPath.3;+Microsoft+Outlook+14.0.6117;+ms-office;+MSOffice+14) - 200 8790

Why is it skipping this IP address and it also appears to be
skipping on the sc-byte value of 8790????

Any help would be appreciated, I just want to remove this client from my

Thanks in Advance