Firefox 3 RC2 and AWStats 6.8 build 1910

Developers
Eric
2008-06-05
2012-10-11
  • Eric

    Eric - 2008-06-05

    Hello,

    Locally under Windows Vista, the .jpg or .png files (flags, etc.) are not displayes since Firefox 3 RC1 and now RC2.

    That works correctly using IE to display statistics locally.

    I have the 'french' message in the Error Console :

    "Sélecteur attendu.Jeu de règles ignoré suite à un mauvais sélecteur." Ligne 41
    qui correspond apparemment à la fin de la feuille de style... ( //--> )

    Laurent j'ai des icones à te transmettre si tu veux.

    Eric

     
    • Slick Willy

      Slick Willy - 2008-06-05

      Jean-Luc also asked: What are the URL's of these .jpg or .png files in the source code of the HTML page
      of the report ?

      Can you see the icons when you directly address them, using the URL?

       
      • Eric

        Eric - 2008-06-06

        Yes, i can display the icon using IE and Firefox.

        When i enter D:/Internet/AWStats/wwwroot/icon/other/vu.png in the URL
        file:///D:/Internet/AWStats/wwwroot/icon/other/vu.png is generated and the icon is displayed

        I don't wants to return to IE :o) !

         
    • Jean-Luc

      Jean-Luc - 2008-06-06

      If this is not a matter of refreshing the caches of your browser, I would say that it looks like a bug in your Firefox release. Did you try other values of DirIcons, like:

      DirIcons="/Internet/AWStats/wwwroot/icon"
      or
      DirIcons="icon"

      If this does not help, upgrade to the Opera browser !... ;o)

      Jean-Luc
      http://www.internetofficer.com/awstats/

       
      • Eric

        Eric - 2008-06-06

        Thanks Jean-Luc but i tried without success.

        Eric

         
    • Slick Willy

      Slick Willy - 2008-06-06

      I've been able to reproduce your error - though Firefox 2 does exactly the same thing.

      <img src="D://image.jpg"> results in the protocol error.
      <img src="File:///D://image.jpg"> works fine, as does
      <img src="image.jpg"> and <img src="images/image.jpg">
      when image.jpg is in the same directory as the .html (or in an images subdirectory).

      So, I'd try putting your icon directory on the same partition as awstats, and use a relative address.

      Are you sure the exact same setup worked in Firefox 2?

       
    • Jean-Luc

      Jean-Luc - 2008-06-05

      Bonjour Eric,

      What are the URL's of these .jpg or .png files in the source code of the HTML page of the report ?

      How did you define your DirIcons parameter in the AWStats config file ?

      Jean-Luc
      http://www.internetofficer.com/awstats/

       
      • Eric

        Eric - 2008-06-05

        Bonjour Jean-Luc,

        That was working correctly since several years with Internet Explorer and Firefox 2.
        Now it is not the case with Firefox 3 RC1 & 2.

        My parameter for the icons directory is :
        DirIcons="D:/Internet/AWStats/wwwroot/icon"

        Eric

         
        • Eric

          Eric - 2008-06-06

          To complete my message, the local link :

          file:///D:/Internet/AWStats/myhtml/awstats.mydomain.html works correcly using IE 7 (display icons)
          but does not display icons using Firefox 3 RC2.

          If i right click on a picture and use load image (Charger Image), i have this strange message in French :

          Firefox ne sait pas ouvrir cette adresse car le protocole (d) n'est associé à aucun programme
          Firefox is not able to open this address protocol (d) is not associated with a program

          If it is a Firefox option to activate, i don't know which one.

          Eric

           
    • Slick Willy

      Slick Willy - 2008-06-05

      I can't reproduce your error, using XP Pro and the English FF RC2, and I haven't seen anything like this in the css-discuss maillist.

      The error you cite is a red herring. I get it also (Selector expected. Ruleset ignored due to bad selector.), but the icons are not styled, so it isn't causing the problem.

      1) Try the awstats demo page.
      2) Turn off all css (use the web developer extension), and see if they appear.

      If either works, then there is something wrong with your local set-up.

       

Log in to post a comment.