ExtraSection trouble

colgate
2010-11-04
2012-10-11
  • colgate

    colgate - 2010-11-04

    Hi all, I'm trying something really simple but I keep getting it wrong.

    I have in my log the following lines:

    GET /u/ino/nopass/l.gif
    GET /u/ino/direct/images/btn-apag.gif
    GET /u/ino/direct/link.php?id=137

    and so on...

    I just want to get the stats from the "ino/direct/blablabla" lines.

    I'm trying this:

    ExtraSectionName1="Ino"
    ExtraSectionCodeFilter1="200 304"
    ExtraSectionCondition1=""
    ExtraSectionFirstColumnTitle1="Link"
    ExtraSectionFirstColumnValues1="URLWITHQUERY,\/u\/(ino\/direct\/.*)"
    ExtraSectionStatTypes1=PH
    MinHitExtra1=1

    The "blalba?id=blabla" comes right, but the others files are listed as:

    /u/ino/direct/images/btn-apag.gifjpg
    /u/ino/direct/images/btn-apag.gifgif

    It repeats the extension. Really weird.

    Can some help me?

     
  • Jean-Luc

    Jean-Luc - 2010-11-05

    Hi,

    As /u/ino/direct/images/btn-apag.gifjpg is listed in the extra section, I
    guess you will find that weird URL in the log file too. Note that
    /u/ino/direct/images/btn-apag.gifjpg matches your condition in the
    ExtraSectionFirstColumnValues1.

    Jean-Luc, InternetOfficer AWStats
    Support

     
  • colgate

    colgate - 2010-11-05

    Hi, thank you for your replay. Yeah it matches, but I really don't have that
    weird entry in my logs.

    Below is a snippet of awstats with debug=10

    Fri Nov 5 12:27:33 2010 - DEBUG 4 - Correct format line 1608:
    host=xxx.xxx.xxx.xxx logname=- date=03/Nov/2010:12:31:45 method=GET
    url=/u/ino/direct/images/btn-pp.gif code=304 size=-
    Fri Nov 5 12:27:33 2010 - DEBUG 4 - This is a not already processed record
    (20101103123145)
    Fri Nov 5 12:27:33 2010 - DEBUG 4 - DNS lookup by static DNS cache file asked
    for xxx.xxxx.xxxx.xxxx but not found.
    Fri Nov 5 12:27:33 2010 - DEBUG 4 - Search country (Host=xxxx.xxxx.xxxx.xxxx
    HostResolved=* ip=4)
    Fri Nov 5 12:27:33 2010 - DEBUG 4 - Process extra analyze 1
    Fri Nov 5 12:27:33 2010 - DEBUG 5 - Check code '304' must be '200'
    Fri Nov 5 12:27:33 2010 - DEBUG 5 - Check code '304' must be '304'
    Fri Nov 5 12:27:33 2010 - DEBUG 5 - No check on code or code is OK. Now we
    check other conditions.
    Fri Nov 5 12:27:33 2010 - DEBUG 5 - No condition or condition is OK. Now we
    extract value for first column of extra chart.
    Fri Nov 5 12:27:33 2010 - DEBUG 5 - Key val was found: ino/direct/images/btn-
    pp.gifgif

    The first line shows the correct log line, but the key val awstats returns is
    wrong :(

     
  • Jean-Luc

    Jean-Luc - 2010-11-05

    Quite strange... What version of AWStats are you using and with which plugins
    ?

    Jean-Luc, InternetOfficer AWStats
    Support

     
  • colgate

    colgate - 2010-11-05

    awstats 6.7 (build 1.892), the latest in ubuntu 8.04.4 lts. I've enabled just
    the tooltip plugin.

    I can post the config file if you want.

     
  • colgate

    colgate - 2010-12-03

    Well, I'm stuck :(

     
  • colgate

    colgate - 2011-03-10

    Just to let you know, after upgrading to the latest version (7.0) it started
    to work fine :|

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks